0.85 x86: Reload doesn't reload Comment for view.

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
Dominius
Posts: 35
Joined: Mon Nov 28, 2016 9:58 am

0.85 x86: Reload doesn't reload Comment for view.

Post by Dominius » Thu May 11, 2017 4:27 pm

I have {Comment} as the last tag visible in ordinary window mode and Full-screen. When I write a JPEG comment to a file fro the command line (usually Exiftool 10.10) with XnView running, then select "Reload" from the File menu, I don't see the new Comment. But I do in the Browser. Am I missing some dependencies, or is it a bug in the application?

I installed MP from the repos using apt-get. Some time afterward, I installed something that UN-installed quite a few items, some of which looked vaguely graphics-related. This is why I ask the first question now.

Dominius.

User avatar
xnview
Author of XnView
Posts: 30270
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85 x86: Reload doesn't reload Comment for view.

Post by xnview » Tue May 16, 2017 2:22 pm

you means the 'Info'? I can't reproduce, when reloading the image, info is updated
Pierre.

Dominius
Posts: 35
Joined: Mon Nov 28, 2016 9:58 am

Re: 0.85 x86: Reload doesn't reload Comment for view.

Post by Dominius » Sat May 27, 2017 2:15 pm

xnview wrote:you means the 'Info'? I can't reproduce, when reloading the image, info is updated
It used to, and is Supposed To, reload it in viewer when I <File><Reload> the image. It doesn't do that. Why it would appear instantly in Browser mode is something I can't explain either. This still happens after I've purged and reinstalled 0.85 from the repos.

D.

Dominius
Posts: 35
Joined: Mon Nov 28, 2016 9:58 am

Re: 0.85 x86: Reload doesn't reload Comment for view.

Post by Dominius » Mon Jul 31, 2017 5:30 pm

This same flaw persists in .86. "Open" pictures do not update with comments/new comments written from the command line, when "File>Reload is 'run,' but pictures left "closed" in the Browser (or the same picture/s as seen in the Browser) will update with the changed/new comments if i click "View>Rebuild thumbnails." This is very frustrating, and I can't see why this last action should be necessary, as gthumb (version 3.4.3) has no problem instantly updating this field.

D.

User avatar
xnview
Author of XnView
Posts: 30270
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85 x86: Reload doesn't reload Comment for view.

Post by xnview » Tue Aug 01, 2017 11:09 am

Dominius wrote:This same flaw persists in .86. "Open" pictures do not update with comments/new comments written from the command line, when "File>Reload is 'run,' but pictures left "closed" in the Browser (or the same picture/s as seen in the Browser) will update with the changed/new comments if i click "View>Rebuild thumbnails." This is very frustrating, and I can't see why this last action should be necessary, as gthumb (version 3.4.3) has no problem instantly updating this field.
You open a picture file in edit mode, change the comment outside XnView, and choose File>Reload, and comment is not changed?
Pierre.

Dominius
Posts: 35
Joined: Mon Nov 28, 2016 9:58 am

Re: 0.85 x86: Reload doesn't reload Comment for view.

Post by Dominius » Thu Aug 24, 2017 1:14 pm

xnview wrote:
Dominius wrote:This same flaw persists in .86. "Open" pictures do not update with comments/new comments written from the command line, when "File>Reload is 'run,' but pictures left "closed" in the Browser (or the same picture/s as seen in the Browser) will update with the changed/new comments if i click "View>Rebuild thumbnails." This is very frustrating, and I can't see why this last action should be necessary, as gthumb (version 3.4.3) has no problem instantly updating this field.
You open a picture file in edit mode, change the comment outside XnView, and choose File>Reload, and comment is not changed?
Exactly.

User avatar
xnview
Author of XnView
Posts: 30270
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85 x86: Reload doesn't reload Comment for view.

Post by xnview » Mon Sep 04, 2017 11:42 am

do you have tried the 0.87 beta?
Pierre.

Dominius
Posts: 35
Joined: Mon Nov 28, 2016 9:58 am

Re: 0.85 x86: Reload doesn't reload Comment for view.

Post by Dominius » Fri Nov 09, 2018 7:13 pm

Well, it's been more than a year, and the version I now have installed is 0.89. The problem persists, but I'm now inclined to think it's my system hardware (Dell Inspiron 1720, 2GB RAM). Mainly because, in the interim versions, installed from debs here and on the Ubuntu repositories, the issue remained as I described it.

D

User avatar
xnview
Author of XnView
Posts: 30270
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85 x86: Reload doesn't reload Comment for view.

Post by xnview » Tue Nov 13, 2018 12:16 pm

and with 0.92?
Pierre.

Post Reply