XnView MP: Moving images while in fullscreen mode does not advance as expected

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

Post Reply
kentavv
Posts: 12
Joined: Fri Apr 24, 2020 4:46 pm

XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by kentavv »

On a Windows 10 system, using XnView MP 0.96.1, while in fullscreen mode (F11) in a directory filled with lots of large images, after moving an image (alt-M), the next image appears and then immediately another. With large images, where there is some latency, the settling time required after a move is disorientating. This is especially noticeable when reviewing and sorting images where it's important that XnView does not skip an image. I hope this is easy to replicate and please let me know if more information is required.

XnView MP Windows
Version 0.96.1 64bits (Apr 19 2020)

Thank you
User avatar
xnview
Author of XnView
Posts: 35849
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by xnview »

kentavv wrote: Fri Apr 24, 2020 4:52 pm after moving an image (alt-M), the next image appears and then immediately another.
you can reproduce each time?
Pierre.
kentavv
Posts: 12
Joined: Fri Apr 24, 2020 4:46 pm

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by kentavv »

Yes, every time, except when the selected image is the first or the last. The problem is seen in fullscreen mode and not in thumbnail mode. The images are 8000x6000, 33MB PNGs served over CIFS and the thumbnails are 800x800 WEBPs. Please let me know if more information would be helpful.
Thank you
User avatar
xnview
Author of XnView
Posts: 35849
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by xnview »

kentavv wrote: Tue Apr 28, 2020 9:37 pm Yes, every time, except when the selected image is the first or the last. The problem is seen in fullscreen mode and not in thumbnail mode. The images are 8000x6000, 33MB PNGs served over CIFS and the thumbnails are 800x800 WEBPs. Please let me know if more information would be helpful.
Strange, i can't reproduce. You click on a file in thumbnail view, press F11? Do you use 'read ahead'/'cache behind' settings?
Pierre.
kentavv
Posts: 12
Joined: Fri Apr 24, 2020 4:46 pm

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by kentavv »

Thank you for checking. This seems solved. I updated to 0.96.2 recently and can no longer reproduce my original problem, which is excellent! (I do have the 'Read one image ahead' and 'Keep current image' options enabled.) Two licenses purchased. If interested, I use XnView to review images, at a course (thumbnail) and fine (full screen zoomed in) level, and move (Alt-m) them to a directory to be taken up by a neural network training system.
kentavv
Posts: 12
Joined: Fri Apr 24, 2020 4:46 pm

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by kentavv »

Oops, the problem still exists. Here is a video showing the oddity after Alt-M is pressed. Perhaps the previous image is shown and then advanced? Regardless, the behavior is disorienting. (Related to moves, often the image counts in the folder don't update properly when moving files.) Thank you

https://youtu.be/vY5aU4ccM5I
betteridea
Posts: 10
Joined: Fri May 28, 2021 9:42 pm

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by betteridea »

Same issue here!

After moving an image in full screen (using Alt-M dialog) a previous image appears for about 200ms and then the next image is displayed resulting in a flickering effect. Reproduced every time with ARW (raw) files.

All enabled:
- Read one image ahead
- Keep current image
- Camera RAW, use Embedded Preview
betteridea
Posts: 10
Joined: Fri May 28, 2021 9:42 pm

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by betteridea »

Sadly this setting is not available in XnView MP:

Tools » Options... » General » File Operations » Go to next image when deleting current

Maybe there an option to disable it with the ini file?
User avatar
xnview
Author of XnView
Posts: 35849
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by xnview »

in a folder, you have .arw files, and you move one of them in fullscreen from browser?
Pierre.
betteridea
Posts: 10
Joined: Fri May 28, 2021 9:42 pm

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by betteridea »

I was moving them via Alt-M dialog in Full Screen. I wasn't really using Browser mode in XnView at all. Let me know if you need more details!

I really like XnView, but for now I switched to a different viewer because of this glitch.
User avatar
xnview
Author of XnView
Posts: 35849
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by xnview »

how do you open the file, from windows explorer or in a xnview's tab?
Pierre.
betteridea
Posts: 10
Joined: Fri May 28, 2021 9:42 pm

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by betteridea »

Windows Explorer, and I have 'Fullscreen - Viewer' Mode enabled.
User avatar
xnview
Author of XnView
Posts: 35849
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView MP: Moving images while in fullscreen mode does not advance as expected

Post by xnview »

do you have always the problem in 0.99.1?
Pierre.
Post Reply