Question about performance

XnConvert Multi Platform - Windows, MacOSX, Linux

Moderators: helmut, XnTriq, xnview

Yngvarr
Posts: 8
Joined: Thu Mar 31, 2022 4:51 pm

Question about performance

Post by Yngvarr »

Hi,

I've found the latest versions of XnConvert to be rather slow when loading files.
I've went back to the oldest version that I could find that included both the option to show the files in a list or thumbnails, and to allow selection of the amount of cores.
For me, this is version 1.78.

Compared to the latest version, version 1.78 is much faster in processing the properties of the files that are loaded, and doesn't go to "program not responding" when I've clicked "Convert" before it actually starts converting the files.

I wonder if there's any specific reason for that?
Is there something that I can do to speedup the newer version?


Best Regards,

Yngvarr
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Question about performance

Post by xnview »

on Windows? Which image file format?
Pierre.
Yngvarr
Posts: 8
Joined: Thu Mar 31, 2022 4:51 pm

Re: Question about performance

Post by Yngvarr »

Hi,

I'm currently running Windows 10 Pro, version 21H2, build 19044.1586.

I mainly process JPG files.
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Question about performance

Post by xnview »

i don't see difference between the 2 versions. Could you post a screencast showing the difference?
Pierre.
Yngvarr
Posts: 8
Joined: Thu Mar 31, 2022 4:51 pm

Re: Question about performance

Post by Yngvarr »

Hi again,

OK, after some more testing, even the old version of the software that ran fast at first, slows down.

The result is as follows:

1. When adding a folder of pictures, it takes a long time to load to properties of those pictures.
2. When clicking on "Convert" the application becomes unresponsive for a while, before actually starting to convert the pictures.

Is it possible that software that I have installed to generate thumbnails might be the issue here?
I can't really think of any other software that I have installed that would impact the loading of images.
Or perhaps it is related to the windows indexing service that I've turned off, because I don't use Search in Windows.
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Question about performance

Post by xnview »

how many files do you add? which format?
Pierre.
Yngvarr
Posts: 8
Joined: Thu Mar 31, 2022 4:51 pm

Re: Question about performance

Post by Yngvarr »

Hi,

About 1000 Jpeg files.
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Question about performance

Post by xnview »

i've tried with a folder containing 14000 files, and 'add folder' takes 4 sec, Clicking on 'Convert' starts right now.

which image size for jpeg files?
For converting do you use 'multiple cores'?
Pierre.
Yngvarr
Posts: 8
Joined: Thu Mar 31, 2022 4:51 pm

Re: Question about performance

Post by Yngvarr »

Hi,

Average size is 1.5- 2.5 MB, and I do use the option of using multiple cores.

Currently it's set for 18 cores, I have 20 available in total.
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Question about performance

Post by xnview »

1. When adding a folder of pictures, it takes a long time to load to properties of those pictures.
long time for files at the end??

without 'core', 'convert' starts with a delay?
Pierre.
Yngvarr
Posts: 8
Joined: Thu Mar 31, 2022 4:51 pm

Re: Question about performance

Post by Yngvarr »

There's a difference in performance mainly when checking the option to use multiple cores with the slider.

When the option is not checked, the converting starts instantly, and all cores are being used for about 60% across all cores.

When the option is checked, the converting does not start instantly, 1 core gets used for a few seconds on 100% load, and then the converting actually starts and then all cores go to 100% load
Yngvarr
Posts: 8
Joined: Thu Mar 31, 2022 4:51 pm

Re: Question about performance

Post by Yngvarr »

Hi,

I finally found some time to make a recording of what happens.

https://youtu.be/H2OPgnMco00
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Question about performance

Post by xnview »

not easy to see detail, you add a folder with JPEG? but when using multiple core, XnView needs to prepare conversion before to start (check for multi page files)
Pierre.
Yngvarr
Posts: 8
Joined: Thu Mar 31, 2022 4:51 pm

Re: Question about performance

Post by Yngvarr »

Hi again, for some reason the application that i used to record was set to 720p

https://youtu.be/FUmYg7fQ_VI

This recording should have the native resolution of the screen (currently Youtube is still processing the HD version)
So, yes, I add a folder with jpeg files, 98 files, just under 200 MB in total size.