XnView MP on Linux Debian 9 Testing Stretch / Sid do NOT RUN

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

Post Reply
delpher
Posts: 2
Joined: Wed Jan 04, 2017 3:04 pm

XnView MP on Linux Debian 9 Testing Stretch / Sid do NOT RUN

Post by delpher »

Hello.
Thank you for the best image viewer program at Linux!

After installing of
Linux Debian 9 Testing Stretch / Sid x64
I tryed to install the XnViewMP x64. It installed ok, but it cannot run. After running the app, nothing happens.

This is output of the program from terminal:
xnview
xnview/opt/XnView/XnView: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory

If you know the solution of the problem, I'll be happy to know it. In case of not, maybe you'll fix it later.

Thank you.

--
Yours faithfully,
Artem L.
User avatar
xnview
Author of XnView
Posts: 35501
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP on Linux Debian 9 Testing Stretch / Sid do NOT

Post by xnview »

you need to install gstreamer
Pierre.
User avatar
mindeunix
Posts: 6
Joined: Thu Jan 05, 2017 10:23 pm
Location: Lithuania
Contact:

Re: XnViewMP on Linux Debian 9 Testing Stretch / Sid do NOT

Post by mindeunix »

Not so simple "install gstreamer". XnViewMP requires the GStreamer version 0.10, which becomes difficult to obtain on modern GNU/Linux systems because GStreamer 0.10 is no longer maintained (GStreamer 1.x has been the main stable series since 2012).
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
delpher
Posts: 2
Joined: Wed Jan 04, 2017 3:04 pm

Re: XnView MP on Linux Debian 9 Testing Stretch / Sid do NOT

Post by delpher »

Solved with last version XnViewMP Version 0.84 x64 (Jan 17 2017) Libformat version 6.95.
Thank you!
Post Reply