0.83: Slash instead of backslash in copied filename and path

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

geoffm
Posts: 7
Joined: Fri Nov 06, 2015 6:54 pm

0.83: Slash instead of backslash in copied filename and path

Post by geoffm »

When using the Edit > Copy to clipboard > Filename and path function, the path is copied with / instead of \ which makes the path unusable in Windows. I would often use this feature to quickly get the image file in a "browse" dialog to upload it to a website or insert it in a document, however I cannot use this in XnView I have to use Windows Explorer.
geoffm
Posts: 7
Joined: Fri Nov 06, 2015 6:54 pm

Re: slash used instead of backslash in filename and path cop

Post by geoffm »

In case others have had problems with this, I just found a handy workaround: adding file:/// before the path makes it usable in Windows dialogs. At least in Windows 10.
User avatar
XnTriq
Moderator & Librarian
Posts: 5897
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: slash used instead of backslash in filename and path cop

Post by XnTriq »

Bug confirmed for browse mode :bugconfirmed:

See also: copy path but got the wrong slash.
User avatar
xnview
Author of XnView
Posts: 36286
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: slash used instead of backslash in filename and path cop

Post by xnview »

i can't confirm this problem, in browser 'Copy to clipboard>selected filename and path' use \
Pierre.
User avatar
XnTriq
Moderator & Librarian
Posts: 5897
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: slash used instead of backslash in filename and path cop

Post by XnTriq »

Sorry, bug confirmed for browse view mode.
User avatar
xnview
Author of XnView
Posts: 36286
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: slash used instead of backslash in filename and path cop

Post by xnview »

See Issue 980 for details.
Pierre.
User avatar
helmut
Posts: 8225
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83: Slash instead of backslash in copied filename and

Post by helmut »

This problem is supposed to be fixed in XnView MP 0.84 beta 1. Could you please try and confirm the bug fix, geoffm?
User avatar
helmut
Posts: 8225
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83: Slash instead of backslash in copied filename and

Post by helmut »

Just did a test and it worked fine for me. :arrow:Closed.

@geoffm: Please holler if you still have problems with 0.84 beta 4 or higher.