0.82.b3- Close pressing ESC in fullscreen mode not working

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

Post Reply
cadu
Posts: 83
Joined: Thu Mar 15, 2012 10:43 am

0.82.b3- Close pressing ESC in fullscreen mode not working

Post by cadu » Fri Jul 22, 2016 11:45 pm

Hi,

Settings -> General -> Keyboard/Mouse -> "Pressing ESC once quits XnViewMP" -> "Only in fullscreen".

ESC works with the setting "Always", but setting "Only in fullscreen" is not working. You press ESC and nothing is happening.

Thanks!

User avatar
xnview
Author of XnView
Posts: 31598
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.82.b3- Close pressing ESC in fullscreen mode not worki

Post by xnview » Sat Jul 23, 2016 8:07 am

are you in view mode or in browser for fullscreen?
same problem in 0.81?
Pierre.

cadu
Posts: 83
Joined: Thu Mar 15, 2012 10:43 am

Re: 0.82.b3- Close pressing ESC in fullscreen mode not worki

Post by cadu » Sat Jul 23, 2016 12:36 pm

Considering "Pressing ESC once quits XnViewMP" -> "Only in fullscreen":
If I'm in XnView browser, then open image in fullscreen, the ESC will close fullscreen and return to browser. It's OK.
If I'm in Windows Explorer, then open image direct in XnView fullscreen (it's my default photo viewer), the ESC isn't working. Nothing is happening when I press ESC.
The behavior is the same in 0.81.
I recorded my screen showing the issue: https://goo.gl/JvzB3S
I have in mind this setting behaving similarly to Faststone.
Thanks,
Cadu_

User avatar
xnview
Author of XnView
Posts: 31598
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.82.b3- Close pressing ESC in fullscreen mode not worki

Post by xnview » Tue Aug 02, 2016 12:55 pm

what do you have in 'mode when starting with a file'??
Pierre.

cadu
Posts: 83
Joined: Thu Mar 15, 2012 10:43 am

Re: 0.82.b3- Close pressing ESC in fullscreen mode not worki

Post by cadu » Wed Aug 03, 2016 12:37 pm

Settings>General>Startup>Mode when starting with a file>Fullscreen - Browser

User avatar
xnview
Author of XnView
Posts: 31598
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.82.b3- Close pressing ESC in fullscreen mode not worki

Post by xnview » Wed Aug 03, 2016 1:34 pm

cadu wrote:Settings>General>Startup>Mode when starting with a file>Fullscreen - Browser
and if you try 'fullscreen - viewer'?
Pierre.

cadu
Posts: 83
Joined: Thu Mar 15, 2012 10:43 am

Re: 0.82.b3- Close pressing ESC in fullscreen mode not worki

Post by cadu » Wed Aug 03, 2016 1:44 pm

Changed to 'fullscreen - viewer'. Then ESC worked as expected, closing VnView.
Then I changed again to 'Fullscreen - Browser', and ESC is still not working.

JMM72
Posts: 33
Joined: Wed Feb 10, 2016 2:16 pm

0.82.b4- Close pressing ESC in fullscreen works too much

Post by JMM72 » Sat Aug 13, 2016 7:59 pm

I was going to post a bug but I think it's related to this one.

With Beta 3, starting in full screen, setting ESC exits only in full screen mode. I open an image, it opens in full screen, I go to next previous whatever, I press ESC and XnViewMP exits. If I do the same, but first I move to explorer view, when in full screen view ESC brings back to explorer mode. It has been like that for me since I don't know how long. So I can quit XnViewMP after a quick view, or I can use ESC to return to explorer view whenever I want if I'm doing something else other than just viewing.

With Beta 4, it exits always while in full screen, it doesn't matter if I come from command line, opening an image, or if I've opened an image from the explorer view.

I don't know if the intended behaviour is the current one, but the previous behaviour was very handy for me, and I've come accustomed to it so much, that I find myself out of XnViewMP all the time when I don't want to. If it's a bug, please fix it. If not, is it possible to implement again the behaviour I've explained?

Regards.

P.d.: Another thing. I've changed the setting to ESC never exits, for the time being. I started XnViewMP with another file, in full screen mode. I pressed ESC and changed to view mode. I pressed ESC again and it exited the program; since the setting is 'never exit' it's a bug. However, mimicking the previous behaviour, if I enter the explorer mode, ESC never exits the program again. Strange.

P.d.: While testing for UTF-8 recognition in the .keys file, I noticed that exiting the program is not always recognized. I open with any image on full screen, press Ctrl-Q (default I think), and XnViewMP exits. I open again, go to browser, press Ctrl-Q, and it exits. I open again, go to browser, go back to full screen, and it doesn't exit.

Post Reply