0.39 win-x86: icns icon snapshot related bug

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

Post Reply
User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

0.39 win-x86: icns icon snapshot related bug

Post by budz45 » Tue Jan 24, 2012 2:40 am

I do no experience this issue with ICO files.

A.)
Spotlight & Icon snapshot on/off

1. open xnview MP 0.39 x86 (default settings)
2. go to browser open any image
3. drag and drop 512x512 ICNS or RSRC onto opened image
4. draw a spotlight and apply
5. Undo spotlight (ctrl+Z)
6. Now hit the command "Icon Snapshot on/off"
7. program crash!

I do not get this same issue with ICO :D

B.)
Same thing happens with "Enhance colors"

1. open xnview MP 0.39 x86 (default settings)
2. go to browser open any image
3. drag and drop 512x512 ICNS or RSRC onto opened image
4. Open "Enhance colors" on ICNS and play with various dials and apply
5. Undo "Enhance colors" on ICNS (Ctrl+Z)
6. Now hit the command "Icon Snapshot on/off"
7. Program crash!

-Same test reproduction done with other image enhancements such as 'shadow/highlight' concerning ICNS and RSRC

C.)
The same thing happens with "Crop" & ICNS/RSRC

1. open xnview MP 0.39 x86 (default settings)
2. go to browser open any image
3. drag and drop 512x512 ICNS or RSRC onto opened image
4. Do a "Crop" on ICNS or RSRC (dont save image)
5. Now hit the command "Icon Snapshot on/off"
6. Program crash!

So if a user does "Crop" any unsaved icon then "Icon Snapshot on/off" should still be able work and show original snapshot. It is only once the "crop" has been saved to the ICNS then it would show an updated different snapshot which would just be a single icon-page snapshot. if you do the same "crop" reproduction test with ICO then everything works just as I've explained it should work (no crash or anything). A Cropped ICO (unsaved) displays original snapshot with no issues :)

tested on windows 7
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

User avatar
xnview
Author of XnView
Posts: 30023
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.39 win-x86: icns icon snapshot related bug

Post by xnview » Thu Apr 19, 2012 9:17 am

Please check XnViewMP 0.48
Pierre.

User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: 0.39 win-x86: icns icon snapshot related bug

Post by budz45 » Thu Apr 19, 2012 11:45 pm

xnview wrote:Please check XnViewMP 0.48
Thank you. Fixed in XnViewMP 0.48 :)
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

Post Reply