[SOLVED]XnView MP 0.35 can't start under ArchLinux

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderators: helmut, XnTriq, xnview

meoow
Posts: 10
Joined: Sat Nov 20, 2010 6:06 am

[SOLVED]XnView MP 0.35 can't start under ArchLinux

Post by meoow »

I'm a ArchLinux user.
XnView MP 0.35 and XnConvert 0.98 used to work fine under my system, but recently both of them can not start.
I tried to run the shell script in terminal, then got the error message below:

Code: Select all

Cannot mix incompatible Qt library (version 0x40702) with this library (version 0x40701)
./xnview.sh: line 5:  3218 Aborted                 "$dirname"/xnview "$@"
I think it's Qt version updated to 4.7.2 few days ago when I updated my system that may cause the problem.
Is there any way can fix it?
Last edited by meoow on Sat Mar 05, 2011 12:56 pm, edited 1 time in total.
User avatar
xnview
Author of XnView
Posts: 37889
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnView MP 0.35 can't start under ArchLinux

Post by xnview »

Which version of ArchLinux?
Pierre.
meoow
Posts: 10
Joined: Sat Nov 20, 2010 6:06 am

Re: XnView MP 0.35 can't start under ArchLinux

Post by meoow »

ArchLinux dose not have a specific version like other distributions such as Fedora or Ubuntu but uses a rolling release system.

Good news, I just updated the system, and my KDE version is up to 4.6.1, and XnView MP works again. Problem solved in spite of I don't know why.

Still thank you for replying.