1.5.3 - complex bug, unable to open image in browser a second time

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

xmozg
Posts: 58
Joined: Fri Sep 24, 2021 3:31 pm

1.5.3 - complex bug, unable to open image in browser a second time

Post by xmozg »

win10x64. Attention: complex bug.

After turning off the "Create thumbnails for whole folder" setting and using "Thumbnails per column" (or "Thumbnail size pixels", but you need to move the slider) to change the size of the thumbnails, you can open the already selected (blue rectangle around file) file in the browser with the mouse double click (or by pressing Enter) only once. Repeatedly using mouse double click or Enter key on selected file will no longer open it in the normal way, instead it will be opened by the "default" (associated) program in a NEW window. Only through the Open context menu (in xnview's browser) will it be possible to open the file normally second and other time. Xnview stops treating files as its own images in this case, because if you enable "Custom filter - all other files - open with - none" in the settings, these files will not perform actions on Enter and double click at all.
User avatar
xnview
Author of XnView
Posts: 44009
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.3 - complex bug, unable to open image in browser a second time

Post by xnview »

if you enalbed "Create thumbnails for whole folder", no more problem?
Pierre.
xmozg
Posts: 58
Joined: Fri Sep 24, 2021 3:31 pm

Re: 1.5.3 - complex bug, unable to open image in browser a second time

Post by xmozg »

xnview wrote: Fri Aug 25, 2023 8:08 am if you enalbed "Create thumbnails for whole folder", no more problem?
There will be no problem. The bug has two necessary conditions - turning off "Create thumbnails for whole folder" and enabling the "Thumbnails per column" mode (or "Thumbnail size pixels" with the need to move the slider after that).
User avatar
xnview
Author of XnView
Posts: 44009
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.3 - complex bug, unable to open image in browser a second time

Post by xnview »

i can't reproduce, please send me your xnview.ini
Pierre.