Dark selection colour

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Dark selection colour

Post by philalethia »

I recently updated from 1.0, to 1.5.2
(on Windows 7)

Everything seemed fine, until I tried having the button "category search" and pressed it, to see what it did.
It did nothing.
All it does, is switch marking on the selected file (the blue colour around it, that shows that it is selected), to a darker colour. And then back again, when it is pressed again.

...but after that, anything I select is marked with a significantly darker colour.
A colour that makes it much harder to see/read the filename and label, and the like.
It's very annoying.
The darker colour is also used in settings, so that the selected section is marked in the dark colour.
The colour is also used for the progress bar, showing the progress of updating the thumbnails/folder, when one enters a different folder (or selects/deselects "show files in subfolders")

Checking a screenshot, in an image editor (I never use Xnview, in that capacity), I note that the old regular colour, is (in decimal) 33,100,168, and the darker colour is 10,36,106.

I've attached a screenshot, that shows the darker colour ...and how anything that is selected in a different panel than the one in focus, reverts to the old colour. (so the marked folder, in the folders panel, is marked with the old colour, but the file, in the browser panel, is marked in the darker colour)
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Dark selection colour

Post by xnview »

you means that selection was not the same in 1.0?
Pierre.
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

xnview wrote: Wed Aug 02, 2023 4:01 pm you means that selection was not the same in 1.0?
Indeed not.
It wasn't the same in 1.5.2 either, until I tried using "category search"
...nor is it the same, in 1.5.2, on my other computer.

In 1.0, and 0.99.7, and also after the upgrade (up until I tried "category search", after which it used the darker colour), as well as on my other computer (on which I also used the aforementioned versions. I'll call the computer I mention in the first post, computer A, and the other one as B), anything that is selected, used/uses the lighter colour.

Well, actually, now that I look more closely at the behaviour of XnView MP, on computer B, things that are selected, but not in the panel that is in focus, has a darker colour (so the opposite behaviour, of what I mention in the first post) ...but it's only slightly darker.
So on computer B, and presumably also the previous behaviour on computer A, non-focused selections have the colour 33,100,168. The colour of focused selection, is 45,132,223.

These colours are fairly similar, and are pretty much in the same, as the colour used in Windows, most other programs, and most other operating systems, for marking selections.
Pretty much the universal colour, for selections. (with perhaps some slight variation, that you wouldn't notice, unless looking at them closely, side by side)

On computer A, after I tried to use "category search" (which, again, did nothing), it not uses the darker 10,36,106, for focused selections, whilst still using 33,100,168 for non-focused selections.

The darker colour (10,36,106), is terrible, insufferable, and makes it almost impossible to read anything, that is selected:
File names, folders in the folders panel, sections in settings, categories in the categories panel...
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

Screenshot from computer B
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Dark selection colour

Post by xnview »

could you send a screenshot of 1.0 and latest version?
Pierre.
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

xnview wrote: Sun Aug 20, 2023 2:00 pm could you send a screenshot of 1.0 and latest version?
...
The from computer B, is of the latest version.
As for 1.0...
That would require me to completely uninstall the program, and then install 1.0.
There is no way I'd do that.

The screenshot from computer B, however, has the colours that I've had, in the latest version, 1.0, and 0.99.7.
In both computer A and B
...except that computer A, only after I pressed on "category search", is now the way that is shown in the first screenshot.
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

I don't have access to computer A, at the moment, but I should definitely do another screenshot from it, were some marked text can be seen, to illustrate how nearly impossible it is, to read, when marked with the darker colour.
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

Here:
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Dark selection colour

Post by xnview »

philalethia wrote: Fri Aug 25, 2023 4:46 pmHere:
with 1.0?
and with 1.5.3?
Pierre.
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

xnview wrote: Sat Aug 26, 2023 2:39 pm
philalethia wrote: Fri Aug 25, 2023 4:46 pmHere:
with 1.0?
and with 1.5.3?
No, the dark colour, shown in the latest screenshot I posted, is only from 1.5.3 but only after I pressed on after I pressed on "category search".
And as you can see, it is practically impossible to read.

Before that, and on the other computer, as well as on 1.0 and 0.99.7, on both computer, it was as in the second screenshot I've posted here. The one in the comment that says "<Screenshot from computer B".
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Dark selection colour

Post by xnview »

strange perhaps a specific problem with Win7, on Win10 here is
Clipboard-2.png
Clipboard-1.png
You do not have the required permissions to view the files attached to this post.
Pierre.
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

xnview wrote: Sun Aug 27, 2023 7:43 am strange perhaps a specific problem with Win7, on Win10 here isClipboard-2.pngClipboard-1.png
It wasn't like that, on Win7.
It was the same as in your screenshot!
...until I pressed "category search".
After that, it's the dark colour.
Before I did that, it was (I repeat) the same as in your screenshot.
User avatar
xnview
Author of XnView
Posts: 43897
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Dark selection colour

Post by xnview »

the second screenshot is when thumbnail view has no more focus
Pierre.
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

xnview wrote: Tue Aug 29, 2023 7:20 am the second screenshot is when thumbnail view has no more focus
The second of your screenshots? Yes, that is what I assumed to be the case.
And as I've said, that is how it's worked on both my computers, under all versions I've used ...except in the latest, after I pressed on "category search". (whether or not this may have happened, in earlier versions, had I done so, I do not know. I also cannot confirm, if it would happen on computer B ...as I refuse to risk it happening, on there as well)
...and when I say "dark colour" I'm, of course, not referring to your screenshots, but to the darker blue colour, in my first and third screenshot.
philalethia
Banned
Posts: 139
Joined: Tue Aug 01, 2023 10:20 am

Re: Dark selection colour

Post by philalethia »

I still have the dark colour, and am practically unable to read any selected (and in-focus) text.
Even after some upgrades.
...and, again, this was never a problem on my Windows 7 computer, with earlier versions, nor initially with 1.5.2. It was only after I pressed on the "category search"-button, that it became a problem.