1.5.0 b2 Thumbnail getting regenerated again.

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

FKCapitalism2
Posts: 238
Joined: Sun Apr 23, 2023 5:14 am

1.5.0 b2 Thumbnail getting regenerated again.

Post by FKCapitalism2 »

Below is done using XnView MP interface.

Scenario 1 (proper operation):

I have image in the folder "One" (thumbnails already generated for images), then i create new folder "MyGallery" and move folder "One" into "MyGallery" by cut (Ctrl+X) and paste (Ctrl+V).

In this case XnViewMP updates catalog so thumbnails and does not re-regenerate thumbnails for images when i navigate to folder "One".

Scenario 2 (bug):

I have image in the folder "One" (thumbnails already generated for images), then i create new folder "MyGallery" and move image files from within folder "One" into my "MyGallery" by cut (Ctrl+X) and paste (Ctrl+V).

In this case XnViewMP DOES NOT updates catalog, so thumbnails for images need to regenerate again.

Scenario 3 (bug):

My catalog has been deleted completely.

I have folders with images "One" and "Two" as sub-folders to "MyGallery" folder, i navigate to folder MyGallery and go to menu View > Show files in subfolders, after this all images from folder One and Two show and thumbnails generate for them.

After all thumbnails generated i go to menu View > Show files in subfolders to uncheck this option and then i navigate to folder "One" or "Two" and thumbnails are starting to get re-generated again.

P.S. in 3rd scenario for folders with exclusively host video files no re-generation of thumbnails followed.
User avatar
xnview
Author of XnView
Posts: 43132
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.0 b2 Thumbnail getting regenerated again.

Post by xnview »

is it new bug in b2?
Pierre.
FKCapitalism2
Posts: 238
Joined: Sun Apr 23, 2023 5:14 am

Re: 1.5.0 b2 Thumbnail getting regenerated again.

Post by FKCapitalism2 »

xnview wrote: Wed Jun 21, 2023 11:29 am is it new bug in b2?
Scenario 2 is new bug for v1.5.0 B2

Scenario 3 i believe was already in v1.4.5
User avatar
xnview
Author of XnView
Posts: 43132
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.0 b2 Thumbnail getting regenerated again.

Post by xnview »

FKCapitalism2 wrote: Wed Jun 21, 2023 1:40 pm Scenario 2 is new bug for v1.5.0 B2
I can't reproduce, it works always
Pierre.
FKCapitalism2
Posts: 238
Joined: Sun Apr 23, 2023 5:14 am

Re: 1.5.0 b2 Thumbnail getting regenerated again.

Post by FKCapitalism2 »

xnview wrote: Wed Jun 21, 2023 1:56 pm
FKCapitalism2 wrote: Wed Jun 21, 2023 1:40 pm Scenario 2 is new bug for v1.5.0 B2
I can't reproduce, it works always
I installed clean v1.5.0 B2 and with fresh xnviewmp and i am getting bug described in Scenario #2.

Perhaps try with this ARW files https://www.upload.ee/files/15363912/ARW.zip.html


P.S. How about Scenario #3 can you reproduce that? Should i post it as new bug report for v1.4.5?
User avatar
xnview
Author of XnView
Posts: 43132
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 1.5.0 b2 Thumbnail getting regenerated again.

Post by xnview »

i've tried but can't reproduce screen
Pierre.