Preview thumbnails are not rotated

*** Please report new bugs here! ***

Moderators: helmut, XnTriq, xnview, Dreamer

bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Wed Feb 09, 2022 1:52 pm
could you send me these 3 files?
Linked at the bottom of this post already viewtopic.php?p=175542#p175542
FKCapitalism
Posts: 57
Joined: Wed Feb 09, 2022 7:32 pm

Re: Preview thumbnails are not rotated

Post by FKCapitalism »

I have issue with previews generated from Sony *.ARW format.

Images taken when camera is held vertically (90 degree turned / portrait mode) show on folder thumbnails sideways

1.png



once you open folder file previews show in correct orientation.

2.png

Files updated
Here's file: https://www.upload.ee/files/13890416/images.zip.html
You do not have the required permissions to view the files attached to this post.
Last edited by FKCapitalism on Tue Feb 15, 2022 7:47 pm, edited 2 times in total.
FKCapitalism
Posts: 57
Joined: Wed Feb 09, 2022 7:32 pm

Re: Preview thumbnails are not rotated

Post by FKCapitalism »

Another problem i found some out of camera JPEG's taken in Portrait orientation show sideways in thumbnail and when open full screen.

portrait orientation.jpg

File attached https://www.upload.ee/files/13879524/DSC00099.JPG.html
You do not have the required permissions to view the files attached to this post.
FKCapitalism
Posts: 57
Joined: Wed Feb 09, 2022 7:32 pm

Re: Preview thumbnails are not rotated

Post by FKCapitalism »

bege wrote: Mon Jan 31, 2022 7:16 pm Unfortunately the issue is back after editing images.

These 3 files come from a camera that notes the orientation.

This file I have not edited:
Screenshot_312.png

These two files I have edited (only colors, not orientation!):
Screenshot_311.png
In image view the orientation is OK, in browser view it is wrong.

Here are the files:
https://filehorst.de/d/edbfotls
Funny thing, downloaded your files and two photos with red flowers show properly for me, but the other one is sideways.

orientation.png
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 37754
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

FKCapitalism wrote: Fri Feb 11, 2022 5:38 pm Funny thing, downloaded your files and two photos with red flowers show properly for me, but the other one is sideways.
Do you have settings>General>Rotate images EXIF...
Pierre.
User avatar
xnview
Author of XnView
Posts: 37754
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

bege wrote: Wed Feb 09, 2022 1:57 pm
xnview wrote: Wed Feb 09, 2022 1:52 pm
could you send me these 3 files?
Linked at the bottom of this post already viewtopic.php?p=175542#p175542
I have no problem with these 3 files, one (P1020264) has EXIF orientation, and the 2 others have no EXIF orientation, but thumbnails are good.
If you copy them in a new folder?
Pierre.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Mon Feb 14, 2022 9:08 am I have no problem with these 3 files, one (P1020264) has EXIF orientation, and the 2 others have no EXIF orientation, but thumbnails are good.
If you copy them in a new folder?
P1020264 is the one that has not been edited.
Do the files loose their original orientation when the colors are edited with XnView? Does any saving mean that the orientation is changed, not only if orientation is changed?
Since I posted this I opened the folder several times on several days, always wrong orientation of the edited images in browser view, today they are displayed in correct orientation :?:
There must be something inconsistent in displaying the images in browser view.

Additionally once again my question what the issue is with the inconsistency of meta data in these files:

P1020263 (edited):

Tab ExifTool
EXIF: has two entries for Orientation, one at the top, one at the bottom of this part. Top shows "Horizontal (normal)", bottom shows "Rotate 90 CW"
MakerNotes: Rotation shows "Rotate 90 CW"

Tab EXIF
Camera: Orientation "top-left (1)"
MakerNotes: Rotation shows "Rotate 90 CW"

The meta data of not edited images is consistent (either all "Horizontal" and "top-left" or "Rotate" and "right-top").
User avatar
xnview
Author of XnView
Posts: 37754
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

If you re-save the file in edit mode, the orientation field is removed, and image data saved with correct orientation
Pierre.
FKCapitalism
Posts: 57
Joined: Wed Feb 09, 2022 7:32 pm

Re: Preview thumbnails are not rotated

Post by FKCapitalism »

xnview wrote: Mon Feb 14, 2022 9:07 am
FKCapitalism wrote: Fri Feb 11, 2022 5:38 pm Funny thing, downloaded your files and two photos with red flowers show properly for me, but the other one is sideways.
Do you have settings>General>Rotate images EXIF...
It was OFF, i checked it and his images show with proper orientation thumbnail and full screen view, and problem described here also fixed.

However that setting does not fix problem i described here (uploaded files have been updated)
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Tue Feb 15, 2022 7:31 am If you re-save the file in edit mode, the orientation field is removed, and image data saved with correct orientation
Thank you, Pierre, for your answer. But this is, as in your previous answers, only an answer to one of my several asked questions.
The still open issues are
1. not reliable display of thumbnails in browser view (several days wrong orientation, after a week with no program update and no settings changes OK.
2. inconsistent meta data (maybe reason for the first issue?)
3. The {EXIF:Orientation} tag in image view info always shows "top-left (1)", no matter whether the image is rotated or not.
User avatar
xnview
Author of XnView
Posts: 37754
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Preview thumbnails are not rotated

Post by xnview »

bege wrote: Tue Feb 15, 2022 9:02 pm 1. not reliable display of thumbnails in browser view (several days wrong orientation, after a week with no program update and no settings changes OK.
Not easy to understand the problem, i can't reproduce...
2. inconsistent meta data (maybe reason for the first issue?)
??
3. The {EXIF:Orientation} tag in image view info always shows "top-left (1)", no matter whether the image is rotated or not.
When image is loaded, EXIF is always changed
Pierre.
bege
Posts: 65
Joined: Sun Feb 20, 2011 6:27 pm
Location: Germany

Re: Preview thumbnails are not rotated

Post by bege »

xnview wrote: Wed Feb 16, 2022 3:54 pm
bege wrote: Tue Feb 15, 2022 9:02 pm 2. inconsistent meta data (maybe reason for the first issue?)
??
Please, read my post previous:
bege wrote: Mon Feb 14, 2022 5:43 pm Additionally once again my question what the issue is with the inconsistency of meta data in these files:

P1020263 (edited):

Tab ExifTool
EXIF: has two entries for Orientation, one at the top, one at the bottom of this part. Top shows "Horizontal (normal)", bottom shows "Rotate 90 CW"
MakerNotes: Rotation shows "Rotate 90 CW"

Tab EXIF
Camera: Orientation "top-left (1)"
MakerNotes: Rotation shows "Rotate 90 CW"

The meta data of not edited images is consistent (either all "Horizontal" and "top-left" or "Rotate" and "right-top").
xnview wrote: Wed Feb 16, 2022 3:54 pm
bege wrote: Tue Feb 15, 2022 9:02 pm 3. The {EXIF:Orientation} tag in image view info always shows "top-left (1)", no matter whether the image is rotated or not.
When image is loaded, EXIF is always changed
So {EXIF:Orientation} is useless in image view? I cannot see, whether the image is displayed in the original orientation or rotated?
FKCapitalism
Posts: 57
Joined: Wed Feb 09, 2022 7:32 pm

Re: Preview thumbnails are not rotated

Post by FKCapitalism »

bege wrote: Wed Feb 16, 2022 5:17 pm So {EXIF:Orientation} is useless in image view? I cannot see, whether the image is displayed in the original orientation or rotated?
It could be combination of settings you changed previously and thumbnails generated based on this settings that makes images rotate incorrectly.

Do you use registry or *.ini file to save your settings?

Download fresh portable version of XnView MP and make sure your preferences are loaded from *.ini file, also make sure you delete old library or point XnView to new location to create for library.
FKCapitalism
Posts: 57
Joined: Wed Feb 09, 2022 7:32 pm

Re: Preview thumbnails are not rotated

Post by FKCapitalism »

xnview wrote: Mon Feb 14, 2022 9:07 am
FKCapitalism wrote: Fri Feb 11, 2022 5:38 pm Funny thing, downloaded your files and two photos with red flowers show properly for me, but the other one is sideways.
Do you have settings>General>Rotate images EXIF...
On more careful examination i am still facing problem when images taken in portrait orientation show sideways (+90°) on preview.

Settings > General > Rotate images according to EXIF orientation tag only permanently fixes orientation for JPEG's, for ARW (Sony RAW files) it makes no difference with either this setting set ON or OFF.


1. Made new photos today copied ARW (Sony RAW files) from my camera to a new folder then opened in XnView, previews for portrait photos generated with proper orientation.

2. Closed XnView and open again now previews show sideways (+90°).

3. If i select portrait images and go to View > Rebuild Thumbnails they become proper orientation until i close XnView and upon re-opening XnView orientation is broken again.
FKCapitalism
Posts: 57
Joined: Wed Feb 09, 2022 7:32 pm

Re: Preview thumbnails are not rotated

Post by FKCapitalism »

Update, somehow it does manage to save orientation for some files, its unknown to me how.

All there ARW files are new from today.

Note two have link icon (green arrow), and last one does not (red arrow).
1.jpg

After i go to View > Rebuild Thumbnails i get link icon appear, but only until close XnView then it disappears again.
2.jpg
P.S. Tried View > Update catalog from files and View > Update files from catalog and it still does not make this link icon to stick, restarting program erases it.
You do not have the required permissions to view the files attached to this post.