Startup directory seems a bug w/ Specified

*** Please report new bugs here! ***

Moderator: Dreamer

sludgehound
Posts: 1
Joined: Fri Jun 15, 2018 9:26 pm

Startup directory seems a bug w/ Specified

Post by sludgehound »

Subject: 0.85: Crash in Fullscreen when navigating to next image

XnView: MP 0.98.4.0 - 64-bit
OS: Windows 10 - 64-bit

Effect: XnView MP won't remember Startup director in Specified line if alter a filled location

XnView MP will ignore the corrections made to a prior (and saved) directory location text.

To reproduce:
1. See General/Startup Specified: field contains a now non-existing directory location.
i.e., had something like Nikon Files & Tests\XnViewMP jpeg input\ worked for years
Bad OS crash and C: had to be rebuilt using Windows Recovery. WR put in above location.
But now I had renamed the Folder to just Nikon Files Tests\....
So I just clicked within the field and deleted the &
Click Ok. Relaunch program. Keeps going to the different C: folder where a new XnViewMP
had to be installed to.
Tried everything. Finally read posts here. Clicked on LAST option for Startup directory & bingo
it opened right to new Folder. Got me to wonder why the Specified identical location fails.
Well IF I had NOT just tried to alter the text and selected a Folder location using the Search box
to right of text field the program would have found it.
This wouldn't happen if text field is blank to begin with, or fully deleted the now changed Folder name
and retyped new string, or more likely (who likes typing) one uses that search box to point to new existing
location. Program just really picky about how it is told about changes.
Tried and failed originally to point to new Folder via the .ini file. No go as long as the existing Specified
field had the now non-existing directory in it.
Likely if Startup directory is set to LAST then no problem, assuming haven't renamed it.
Anyway really a big deal since a Startup directory would seem to be more "real time" responsive with a
message about not finding or invalid location initially.
All I did was to delete the one & which program accepted when hit Ok since it was a proper location.
Just somehow program got locked into that non-existing directory made in the pre-system crash.
I should have figured severe crash would have its set of issues, but the fact that program actually was
pre-filled with a year old, now gone in crash-rebuild, location did alert me at last there was trouble.
Hope saves someone from having problems getting Startup direction to "take".
I was so freaked I was ready to search for a string to add to a desktop icon target line pointing right to the new Folder. Like in old DOS days to point to a specific folder on C: drive when launched Explorer to save some typing steps.
Really like the program a lot. Reduces files size, stays sharp. Been a while since new version? sludgehound