Page 1 of 1

Guetzli JPEG Encoder does not work

Posted: Sat Jul 13, 2019 8:33 am
by masterjp
Today I want to test the Guetzli jpeg encoder, but it did not work. In the past it worked very well.

I loaded a jpeg file (4000x3000 pixel), resized the picture to 2048 (longest side) and use the save as dialog to save it. I do not get a file.

Re: Guetzli JPEG Encoder does not work

Posted: Sat Jul 13, 2019 9:41 am
by cday
masterjp wrote:
Sat Jul 13, 2019 8:33 am
Today I want to test the Guetzli jpeg encoder, but it did not work. In the past it worked very well.

I loaded a jpeg file (4000x3000 pixel), resized the picture to 2048 (longest side) and use the save as dialog to save it. I do not get a file.

I believe past experience is that the Guetzli encoder can take a *very* long time to produce an output for an image with large pixel dimensions, and think I recall reading when it was introduced that it was principally intended to reduce the filesize of images on downloaded on web pages...

The Wikipedia Guetzli page among other resources online should provide some background.

Re: Guetzli JPEG Encoder does not work

Posted: Sat Jul 13, 2019 3:26 pm
by masterjp
It is a pity that Google or the developers of Guetzli Encoder do not develop the program further. Multi-threading support would make it more attractive. But you are right. Mozilla's JPEG encoder is much faster and comparable.

Re: Guetzli JPEG Encoder does not work

Posted: Sat Jul 13, 2019 8:30 pm
by XnTriq
Related:
xnview wrote:
Wed Mar 27, 2019 2:55 pm
Elk wrote:
Wed Mar 27, 2019 2:05 pm
Yes, that works. Why does it not work with the other one?
There is some limitation of pixels size with jpeg Guetzli
m.Th. wrote:
Tue Jan 30, 2018 9:34 am
xnview wrote:yes, guetzli has a limitation, you need to use quality >= 84
First off, this should be mentioned in a stop dialogue / warning /ban etc.

Even so it has problems. If I try to convert CR2 (Raw option = 'embedded preview') files to Guetzli JPG it runs forever. Clicking on [x] button from Batch Convert it closes the dialog before it finishes (!), but the Guetzli.exe is still running in the background consuming an entire core and a lot of memory.

Also, with simple JPEG it seems to fail if in Write Settings the 'Rebuild embedded EXIF thumbnail' option is checked.

Re: Guetzli JPEG Encoder does not work

Posted: Sat Jul 13, 2019 8:59 pm
by masterjp
My mistake. I used 80 % quality setting for guetzli. :-(

Re: Guetzli JPEG Encoder does not work

Posted: Sat Jul 13, 2019 9:05 pm
by XnTriq
masterjp wrote:
Sat Jul 13, 2019 8:59 pm
My mistake. I used 80 % quality setting for guetzli. :-(
Thanks for reporting back, masterjp (-:

A warning message (as requested by m.Th.) would be highly desirable.