Page 1 of 1

Pressing ESC Once Quits (despite setting)

Posted: Wed May 01, 2019 5:22 am
by metal450
XnViewMP 0.93.1 64bit on Win10.

With Settings->Interface->Keyboard->Pressing ESC once quits XnViewMP set to "Never," if I double-click a jpg (to open it in the viewer), then press ESC once...it quits.

Note: the bug doesn't exist in "browser mode," where pressing esc won't exit the software - it only happens in "view mode."

Re: Pressing ESC Once Quits (despite setting)

Posted: Mon May 06, 2019 12:44 pm
by xnview
the problem is that ESC close tab, so what should happened? In browser mode, it returns to browser

Re: Pressing ESC Once Quits (despite setting)

Posted: Mon May 06, 2019 5:38 pm
by metal450
If the option is set to allow ESC to quit, then it makes sense that it would quit;
If the option is set not to allow ESC to quit, it should just do nothing (aka leave the last tab/viewed-image open). This is how the similar option behaves in IrfanView, for instance.

Re: Pressing ESC Once Quits (despite setting)

Posted: Mon Aug 26, 2019 3:38 pm
by xnview
i've tried to reproduce, but i can't. Do you use Settings>General>Mode when starting - 'Fullscreen - viewer'?

Re: Pressing ESC Once Quits (despite setting)

Posted: Wed Sep 04, 2019 3:53 am
by metal450
Sorry, I don't understand the question - under Tools -> Settings -> General, I don't see any instance of the word "Mode".

Re: Pressing ESC Once Quits (despite setting)

Posted: Wed Sep 04, 2019 6:13 am
by cday
xnview wrote:
Mon Aug 26, 2019 3:38 pm
I've tried to reproduce, but I can't. Do you use Settings>General>Mode when starting - 'Fullscreen - viewer'?
metal450 wrote:
Wed Sep 04, 2019 3:53 am
Sorry, I don't understand the question - under Tools -> Settings -> General, I don't see any instance of the word "Mode".

I think the setting referred to is:

Tools > Settings > General -- General tab --Startup -- Mode when starting with a file [Normal, Fullscreen - Viewer, Fullscreen - Browser]

Re: Pressing ESC Once Quits (despite setting)

Posted: Wed Sep 04, 2019 7:11 am
by metal450
Oh duh, sorry I don't know how I missed that. I use mode=Normal.