0.92: XnViewMP not showing webp images when opened from Windows Explorer

*** Please report new bugs here! ***

Moderator: Dreamer

User avatar
Mapaler
Posts: 39
Joined: Thu Nov 05, 2015 9:23 am
Location: China

Re: 0.92: XnViewMP not showing webp images when opened from Windows Explorer

Post by Mapaler »

XnViewMP does not have parameters with "open" command by default.
I've been modifying the registry myself for years. Now think it may be escalated as a bug?
Save the following code as a *.reg file, and run it. The path to XnViewMP needs to be modified

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Applications\xnviewmp.exe\shell\open\command]
@="\"E:\\Program Files\\XnViewMP\\xnviewmp.exe\" \"%1\""
That is, add "%1" at the end of the registry value HKEY_CLASSES_ROOT\Applications\xnviewmp.exe\shell\open\command
After you do this, you can set any file to open by XnViewMP, Includes rare formats such as DICOM.

Image
Image
anonymous_user
Posts: 17
Joined: Tue Dec 13, 2011 2:37 am

Re: 0.92: XnViewMP not showing webp images when opened from Windows Explorer

Post by anonymous_user »

Ok I just tested with XnViewMP 0.99.1 and it seems to be working. I can open webp files from Windows Explorer and they will display in XnViewMP. Fingers crossed it stays working.
erty
Posts: 4
Joined: Tue Apr 11, 2017 1:03 am

Re: 0.92: XnViewMP not showing webp images when opened from Windows Explorer

Post by erty »

Same issue. Windows 11 x64, XnView 0.99.1. Png and jpeg open fine, but exactly same problem with webp.
I suspect it because .webp not in the system list of default extensions for XnView.
(Or maybe it happened after I installed ACDSee and it reassigned some files to itself)
https://paste.pics/ETX4E
Same settings for AcdSee for example:
https://paste.pics/ETX58

P.S. recommendation to add "%1" into "\HKEY_CLASSES_ROOT\webp_auto_file\shell\open\command"
Solved the problem for me, but this solution may be not so easy for everyone.
anonymous377
Posts: 1
Joined: Fri Dec 03, 2021 7:53 pm

Re: 0.92: XnViewMP not showing webp images when opened from Windows Explorer

Post by anonymous377 »

Also have 0.99.1 version on Windows 10 and got this problem, every images works fine, only webp wont open. Please fix that problem on newer versions.
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.92: XnViewMP not showing webp images when opened from Windows Explorer

Post by xnview »

anonymous377 wrote: Fri Dec 03, 2021 7:55 pm Also have 0.99.1 version on Windows 10 and got this problem, every images works fine, only webp wont open. Please fix that problem on newer versions.
it seems that you have a problem in your registry entries
Pierre.