0.92 'Update or create XMP Sidecar' setting doesn't work [Linux]

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
mahikeulbody
Posts: 138
Joined: Sun Dec 13, 2009 4:54 pm

0.92 'Update or create XMP Sidecar' setting doesn't work [Linux]

Post by mahikeulbody » Thu Oct 04, 2018 10:11 am

XnView MP Linux
Version 0.92 64bits (Sep 18 2018)

set 'Update or create XMP Sidecar'
set IPTC/XMP Editor to work as 'XMP only'

set/modify some metadata ('City' as an example), write the metadata

=> there is no sidecar created

User avatar
michel038
Posts: 215
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: 0.92 'Update or create XMP Sidecar' setting doesn't work [Linux]

Post by michel038 » Thu Oct 04, 2018 12:17 pm

IPTC/XMP Editor doesn't use "Settings, Metadata"

You can create XMP sidecar only when using categories.
XMP sidecar will contain xmp:subject , xmp:lr:hirarchicalSubject , xmp:rating, xmp:label and no other metadata

Other way to create xmp files with all existing xmp metadata (for Windows) :
go to Tools, OpenWith, Configure, Add
create a new entry with ...xnviewmp\addon\exiftool.exe
add this parameters : -o %d%f.xmp -xmp -k

select one or more images, right-clic, open with , exiftool ... xmp-sidecar will be created by exiftool
Perhaps you can use the same method under Linux

Bon, en Français on se comprend aussi, mais si ça peut aider les non francophones ...
Dans ma doc, l'utilisation d'exiftool c'est le chapitre 11N exemple 4

Il y a tout de même un problème d'ergonomie assez sérieux sur ces ensembles de réglages (il y a même un troisième ensemble de réglages dans "conversion par lots, IPTC "

... et une carence de xnviewmp pour ajouter les métadonnées ordinaires dans les XMP sidecar
viewtopic.php?t=36685
Last edited by michel038 on Thu Oct 04, 2018 1:26 pm, edited 1 time in total.

mahikeulbody
Posts: 138
Joined: Sun Dec 13, 2009 4:54 pm

Re: 0.92 'Update or create XMP Sidecar' setting doesn't work [Linux]

Post by mahikeulbody » Thu Oct 04, 2018 1:00 pm

Thanks for the answer.

Post Reply