0.92: "Reset 'Auto Image size' with next/previous file" under Settings>View doesn't seem to have any effect

Bugs which have been reproduced by a second user or the developer

Moderator: Dreamer

Post Reply
xelnavim
Posts: 2
Joined: Tue Oct 02, 2018 6:40 am

0.92: "Reset 'Auto Image size' with next/previous file" under Settings>View doesn't seem to have any effect

Post by xelnavim » Tue Oct 02, 2018 7:06 am

XnView: MP 0.92 - 64-bit
OS: Windows 10 - 64-bit

Effect: Even with "Reset 'Auto Image size'" checked, and with all my "Auto Image Size" preferences set to "No Fit", after zooming in to an image or pressing '/' to fit an image to the screen, moving to the next/previous image maintains that new zoom level or sizing. Even using the Browser to select and open a new image in the Viewer still doesn't reset the image sizing back to "No Fit".

Expected behavior: With the Reset 'Auto Image size' preference toggled, moving to the next/previous image should reset the Viewer to whatever "Auto Image Size" preferences are set.

fireattack
Posts: 24
Joined: Sun Nov 10, 2013 8:02 am

Re: 0.92: "Reset 'Auto Image size' with next/previous file" under Settings>View doesn't seem to have any effect

Post by fireattack » Tue Jan 22, 2019 7:41 am

Can confirm having the same problem.

fireattack
Posts: 24
Joined: Sun Nov 10, 2013 8:02 am

Re: 0.92: "Reset 'Auto Image size' with next/previous file" under Settings>View doesn't seem to have any effect

Post by fireattack » Tue Jan 22, 2019 8:02 am

Actually, want to add more since from my testing, the way it works is pretty messed up.

Settings: auto image size: last used + reset 'Auto Image size' with next/previous file unchecked
Expected: when open an image it uses whatever you have before, and if you change the zoom (fit / no fit), it should be kept when you go next image.
What happened: it will always start as "fit" and reset to "fit" whenever you go next image.

Settings: auto image size: last used + reset checked
Expected: should be same as above since it is "last used" anyway.
What happened: it will always start as "fit" and reset to "fit" whenever you go next image.

Settings: auto image size: no fit + reset unchecked
Expected: start with no fit, and if you change to "fit" (or if you switch back to no fit) during viewing, it should carry to the next image in this session.
What happened: it does start with no fit, but whenever you switch to "fit" once, it will always be "fit" from now on when you go next, switching back to no fit won't be kept to the next image in this tab (until you re-open image from browser mode.)

Settings: auto image size: no fit + reset checked
Expected: start with no fit, and will always reset to "no fit" when you go next image.
What happened: if you change it to "fit", it WILL carry to next image. But this time, if you changed back to no fit during viewing, it will also carry to next image in this tab.

Settings: auto image size: fit to window + reset unchecked
Expected: start with fit, and if you change to "no fit" (or if you switch back to fit) during viewing, it should carry to the next image in this session.
What happened: it does start with fit, but it will always reset to fit when go next, even if you changed to "no fit" during viewing.

Settings: auto image size: fit to window + reset checked
Expected: start with fit, and will always reset to "fit" when you go next.
What happened: it worked as expected. <-- the only case!!

User avatar
xnview
Author of XnView
Posts: 31178
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.92: "Reset 'Auto Image size' with next/previous file" under Settings>View doesn't seem to have any effect

Post by xnview » Mon Feb 04, 2019 1:27 pm

:bugconfirmed: Thanks to your detailed description I can reproduce
Pierre.

Post Reply