Page 1 of 2

0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Wed Sep 12, 2018 8:17 pm
by _Rayman_
I just updated my XnViewMPx64 installation to 0.91 as a portable installation on Windows 10.

I assigned my image file types in Windows accordingly so that XnViewMP is opened when I double click an image file in windows explorer. With 0.91 this functionality stopped: A small progress bar is shown (loading image) and then nothing happens.

The problem can be reproduced by trying the same call on the command shell:

xnviewmp.exe "examplepath/file.jpg"

shows the loading progress bar, then the image/xnviewmp is not shown.

When I start xnviewmp.exe without any image filename as argument then the program works normal.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Thu Sep 13, 2018 9:36 am
by grgr
I can confirm the same behaviour for macOS 10.11.6

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Thu Sep 13, 2018 9:40 am
by deus-ex
Cannot reproduce, commandline argument and association in Windows 10 64-bit works fine here.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Thu Sep 13, 2018 1:32 pm
by xnview
i can't reproduce the problem, what is your setting in General>Mode when starting with a file?

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Thu Sep 13, 2018 2:13 pm
by JMM72
I can confirm this bug.
Windows 7 64bit, 0.91 64bit.

XVMP opens with browsing a folder, or without commandline. With commandline file argument, it doesn't start (process appears briefly in task manager but closes quickly).

In general, mode, I have it opening in full screen - viewer, when opening with an image.

Reinstalling 0.90, and bug doesn't appear, so at least it's not some new library.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Thu Sep 13, 2018 5:34 pm
by eliio
Confirm this bug.
Win 7 64bit, 0.91 64bit.

As JMM72 I have the viewer set to full screen when opening single files from explorer.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Thu Sep 13, 2018 7:43 pm
by _Rayman_
xnview wrote:
Thu Sep 13, 2018 1:32 pm
i can't reproduce the problem, what is your setting in General>Mode when starting with a file?
The Mode setting is "Fullscreen - Viewer" and that seems to be the problem!

I can reproduce the following:

Mode "Fullscreen - Viewer" >> XNViewMP doesn't open
Mode "Fullscreen - Browser" >> XNViewMP opens, but the window is frozen
Mode "Normal" >> XNView opens normally and can be used

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Fri Sep 14, 2018 4:46 am
by deus-ex
_Rayman_ wrote:
Thu Sep 13, 2018 7:43 pm
I can reproduce the following:

Mode "Fullscreen - Viewer" >> XNViewMP doesn't open
Mode "Fullscreen - Browser" >> XNViewMP opens, but the window is frozen
Mode "Normal" >> XNView opens normally and can be used
I have set start-up mode to "Fullscreen - Browser" and thankfully no issues at this time.

Previously though when I tried v0.91 beta 2 I had the frozen screen too, i.e. XnViewMP would start-up and load an image given as a command-line argument, then no further action was possible and XnViewMP had to be terminated via Taskmanager.

An option to try for those currently having similar issues is to start XnViewMP with vanilla settings, i.e. without a xnview.ini (make a back-up copy or rename the file). This has helped me in the past to fix certain issues, but it also requires to do the whole configuration process again. If you manage to get XnViewMP running again, you can use your back-up of xnview.ini as a reference and copy/paste over certain settings. Your choice.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Fri Sep 14, 2018 10:00 am
by deus-ex
xnview wrote:
Fri Sep 14, 2018 8:04 am
Win 7?
_Rayman_ wrote this in his first post:
_Rayman_ wrote:
Wed Sep 12, 2018 8:17 pm
I just updated my XnViewMPx64 installation to 0.91 as a portable installation on Windows 10.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Fri Sep 14, 2018 10:09 am
by xnview
could you try to replace the exe by this one and tell me if it works now?

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Fri Sep 14, 2018 4:36 pm
by JMM72
I've just tried this exe over a freshly installed 0.91 and now it works as expected.
I've also tried to reproduce that other error about cycling mode with Enter key, and it works also as expected with this exe.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Fri Sep 14, 2018 5:02 pm
by deus-ex
JMM72 wrote:
Fri Sep 14, 2018 4:36 pm
I've also tried to reproduce that other error about cycling mode with Enter key, and it works also as expected with this exe.
I tried this EXE, too. Again I removed xnview.ini to start with a vanilla setup. However the issue remains unchanged here, all three switching modes still stop in Viewer mode, no cycling. No such issues with previous release v0.90.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Fri Sep 14, 2018 5:36 pm
by _Rayman_
xnview wrote:
Fri Sep 14, 2018 10:09 am
could you try to replace the exe by this one and tell me if it works now?
With this new EXE file I can reproduce:

Mode "Fullscreen - Viewer" >> XNViewMP opens and shows the image fullscreen, good!
Mode "Fullscreen - Browser" >> XNViewMP opens in fullscreen, when I hit return and get back to XNViewMP viewer the application is frozen

When in "Fullscreen - Viewer" and I cycle one round using enter key: fullscreen > viewer > browser > fullscreen > viewer, then the application freezes as well.

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Mon Sep 17, 2018 8:08 am
by xnview
please try with this EXE

Re: 0.91: Open xnviewmp.exe with image file as argument doesn't work

Posted: Mon Sep 17, 2018 12:07 pm
by grgr
Don't you have a test build for Mac as well?