Mouse scroll no longer works after reaching bottom

*** Please report new bugs here! ***

Moderators: helmut, XnTriq, xnview, Dreamer

mapline
Posts: 17
Joined: Sun Nov 20, 2016 1:41 am

Mouse scroll no longer works after reaching bottom

Post by mapline »

Hi
Small anoying bug is that when in browser mode with mouse wheel set to scroll up/down the scrolling of the page of thumbnails works perfectly until I scoll to the end of the thumbnails. Then the mouse wheel does not page up. If I put the cursor on the side bar the page will scroll up .
Any thoughts
Michael
mapline
Posts: 17
Joined: Sun Nov 20, 2016 1:41 am

Re: Bug in mouse scroll in Browser

Post by mapline »

Subject: 0.89: Bug in mouse scroll in Browser

XnView MP Windows
Version 0.89 64bits (Jan 15 2018) Same problem in previous version

When in browser mode with mouse wheel set to scroll up/down the scrolling of the page of thumbnails works perfectly until I scroll to the end of the thumbnails )bottom of page). Then the mouse wheel does not scroll up. If I put the cursor on the side bar the page will scroll up
Effect: Usability problem as using mouse wheel to scroll images it suddenly stops scrolling. Then have to rember to put cursor on side bar for mouse scroll wheel to work again.

To reproduce:
1. browser mode with mouse wheel set to scroll up/down
2. scroll down to bottom of page with mouse wheel.
3.At botom of page mouse wheel stop working
Place cursor on side bar and mouse wheel will work.



Michael
User avatar
xnview
Author of XnView
Posts: 37757
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Bug in mouse scroll in Browser

Post by xnview »

i can't reproduce on Windows 8.1
Pierre.
mapline
Posts: 17
Joined: Sun Nov 20, 2016 1:41 am

Re: Bug in mouse scroll in Browser

Post by mapline »

Image
https://1drv.ms/u/s!At_1R2gW8i68hL58_FIVztH25HArSQ
Trying to add screen print from onedrive to assist.
It could be that I am using browser in full screen by itself?
Win 10 Pro
mapline
Posts: 17
Joined: Sun Nov 20, 2016 1:41 am

Re: Bug in mouse scroll in Browser

Post by mapline »

Deleted Xnviewmp and .bar, .keys, .ini files.

Reinstalled and setup . Problem gone so it was my machine or my settings not your program.

Thought I'd let you know.
Thanks Michael
Kaetokiha
Posts: 4
Joined: Sat Jun 23, 2018 4:54 pm

Re: Bug in mouse scroll in Browser

Post by Kaetokiha »

I started to use this program 3 days ago and i also encountered this bug. Once the scroll reached bottom it would not move anymore unless i clicked the "first file" button or used the scrollbar.

After reading the above comment i went and deleted everything and then setup the program again and the bug disappeared.

Version 0.90 64bits Windows 7 64bits SP1
Kaminari
Posts: 8
Joined: Wed Sep 07, 2016 9:50 pm

Re: Bug in mouse scroll in Browser

Post by Kaminari »

This bug is still present in XnViewMP 0.94.2. It happens in both Win7 SP1 and Win10 v2004 (Slow Ring).

After some forensics, I determined the culprit to be the option "View scroll the content by thumbnail" in the Browser tab (this option scrolls the contents of the thumbnail browser by one line). Disabling it will work around the bug, but then the vertical scroll speed is accelerated to three lines instead of one.
User avatar
xnview
Author of XnView
Posts: 37757
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Bug in mouse scroll in Browser

Post by xnview »

If option "View scroll the content by thumbnail" is on, you have the problem?
Pierre.
sheepthief
Posts: 2
Joined: Sat Aug 01, 2020 6:53 am

Re: Bug in mouse scroll in Browser

Post by sheepthief »

And it's back in version 0.98. I've not noticed the issue in previous versions, but now it's driving me up the wall.

Doesn't matter what tools > settings > interface > mouse > mouse wheel, is set to.

You can scroll up and down in thumbnail view, until you hit the bottom, and then you can no longer scroll up until you use the slider to move away from the bottom.
User avatar
deus-ex
Posts: 171
Joined: Mon Sep 20, 2004 7:24 pm
Location: Earth

Re: Bug in mouse scroll in Browser

Post by deus-ex »

Windows 10 Pro 64-bit, XnView MP v0.98.1 64-bit

I cannot reproduce this issue, scrolling the icon list in the browser works every time both with 'View scroll the content by thumbnail' en- and disabled.

When 'View scroll the content by thumbnail' is activated, the scrolling is considerably slower. That's probably due to the dynamic horizontal alignment of each icon row during scrolling. When 'View scroll the content by thumbnail' is deactivated, the list scrolls at the normal system-wide speed, but the horizontal positioning of each icon row isn't properly aligned.
freeocha
Posts: 4
Joined: Sat Feb 12, 2022 4:28 pm

Re: Bug in mouse scroll in Browser

Post by freeocha »

xnview wrote: Wed Jan 31, 2018 3:43 pm i can't reproduce on Windows 8.1
I meet the same problem and know how to reproduce it!

In browser mode, when I adjust the "file size(the right top corner adjustable bar)" to 163, this bug occur. It will not happen if it is 158 or 168.
However, file size 163 is a common choice because you can get exactly 10 thumbnail in a row (in 4k monitor). That is convenient.

XnView MP Windows 10(21H2)
Version 0.99.6 64bits
Thumbnail don't use shadow
Border size:0
Margin:0
Thumbnail cell
Background: clicked
Border: unclicked
Spacing:8
And unclicked nearly all "overlay icons"
Only left "filename" in "labels"
User avatar
xnview
Author of XnView
Posts: 37757
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Bug in mouse scroll in Browser

Post by xnview »

freeocha wrote: Wed Mar 30, 2022 11:13 am
xnview wrote: Wed Jan 31, 2018 3:43 pm i can't reproduce on Windows 8.1
I meet the same problem and know how to reproduce it!

In browser mode, when I adjust the "file size(the right top corner adjustable bar)" to 163, this bug occur. It will not happen if it is 158 or 168.
However, file size 163 is a common choice because you can get exactly 10 thumbnail in a row (in 4k monitor). That is convenient.
Please send me your xnview.ini? which font scaling do you use?
Pierre.
freeocha
Posts: 4
Joined: Sat Feb 12, 2022 4:28 pm

Re: Bug in mouse scroll in Browser

Post by freeocha »

xnview wrote: Mon Apr 11, 2022 12:41 pm
freeocha wrote: Wed Mar 30, 2022 11:13 am
xnview wrote: Wed Jan 31, 2018 3:43 pm i can't reproduce on Windows 8.1
I meet the same problem and know how to reproduce it!

In browser mode, when I adjust the "file size(the right top corner adjustable bar)" to 163, this bug occur. It will not happen if it is 158 or 168.
However, file size 163 is a common choice because you can get exactly 10 thumbnail in a row (in 4k monitor). That is convenient.
Please send me your xnview.ini? which font scaling do you use?
150% scaling in windows

I don't know how to upload in this forum, so I upload it in MEGA
Here is the xnview.ini.
https://mega.nz/file/FUgCRazY#nN7720-zR ... 5VXFDzHYqY
User avatar
xnview
Author of XnView
Posts: 37757
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Bug in mouse scroll in Browser

Post by xnview »

freeocha wrote: Mon Apr 11, 2022 9:22 pm Here is the xnview.ini.
https://mega.nz/file/FUgCRazY#nN7720-zR ... 5VXFDzHYqY
this xnview.ini shows the problem?? Could you send me a screenshot too please
Pierre.
freeocha
Posts: 4
Joined: Sat Feb 12, 2022 4:28 pm

Re: Bug in mouse scroll in Browser

Post by freeocha »

xnview wrote: Tue Apr 12, 2022 6:39 am
freeocha wrote: Mon Apr 11, 2022 9:22 pm Here is the xnview.ini.
https://mega.nz/file/FUgCRazY#nN7720-zR ... 5VXFDzHYqY
this xnview.ini shows the problem?? Could you send me a screenshot too please
Here is the screenshot
https://mega.nz/file/5FgFWJAb#Hwr3Wp9xJ ... jMMNXSIG3I

I also record a short video showing the bug
https://mega.nz/file/hVgXxKaY#onCutjWxX ... AGbfiopuwk