0.87: some Viewers buttons aren't working correctly

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
phaolo
Posts: 69
Joined: Tue Dec 29, 2015 11:40 pm

0.87: some Viewers buttons aren't working correctly

Post by phaolo » Sun Nov 26, 2017 8:54 pm

XnView: MP 0.87 64 bit
OS: Windows 7 64bit

In the Viewer:
- if I switch between the buttons "No Fit" and "Fit image to window, large only", the image remains on the second setting.
- the "Real Size" button doesn't stay pressed, but selects "No Fit" instead. The resulting zoom level % is remembered when scrolling to other images.
- "Lock zoom" doesn't have any effect, because the zoom is uncorrectly remembered by default.

To reproduce:
1. open Viewer.
2. try the various buttons, expecially scrolling between different images.

User avatar
xnview
Author of XnView
Posts: 29572
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.87: some Viewers buttons aren't working correctly

Post by xnview » Mon Nov 27, 2017 8:00 am

phaolo wrote:- if I switch between the buttons "No Fit" and "Fit image to window, large only", the image remains on the second setting.
'No fit' use current zoom value
- the "Real Size" button doesn't stay pressed, but selects "No Fit" instead. The resulting zoom level % is remembered when scrolling to other images.
It's normal that 'Real size' doesn't stay pressed, 'Real size' is not like fit settings.
- "Lock zoom" doesn't have any effect, because the zoom is uncorrectly remembered by default.
Pierre.


Post Reply