0.84: Duplicating tabs with subset of items in folder

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
vertigo
Posts: 118
Joined: Wed Feb 15, 2017 3:49 pm

0.84: Duplicating tabs with subset of items in folder

Post by vertigo » Sat Feb 18, 2017 6:34 pm

XnView: MP 0.84 x64
OS: Windows 7 - 64 bit

Effect: When duplicating a tab that contains a subset of items in a folder, the new tab contains ALL items from the folder, and is therefore not a true duplicate.

To reproduce:
1. Make sure Settings > Interface > 'Multiple view for same file' and 'Only one view per file' are checked, set Interface > Tabs > 'Double-click on tab' option to 'Duplicate tab'
2. Select multiple files in the browser, but not all files in the folder
3. Open them in a single tab (supposedly can be done via Ctrl-O shortcut but only works by pressing enter for me)
Actual behaviour (bug): New tab will show total # of files in folder and will cycle through all of them

Expected behaviour: New tab should show # of files selected in step 2 and only cycle through those files

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Duplicating tabs with subset of items in folder

Post by helmut » Mon Feb 20, 2017 8:51 pm

I've tried to reproduce your problem, vertigo, and for some reason I don't know (yet) XnView behaves differently for me. And to be honest I'm not sure what the expected behaviour should be.

- After performing your steps 1-3 using "Ctrl+O" key:
Actual behaviour: XnView opens all selected images - each image in it's own tab.
Expected behaviour: ?

- After performing your steps 1-3 using "Enter" key:
Actual behaviour: XnView opens one tab showing the last selected image.
Expected behaviour: ?

Could you please try and set "Use ENTER to switch between:" to "Do nothing" (this setting is in Tools » Settings | Interface | Switching mode)?

vertigo
Posts: 118
Joined: Wed Feb 15, 2017 3:49 pm

Re: 0.84: Duplicating tabs with subset of items in folder

Post by vertigo » Mon Feb 20, 2017 10:42 pm

helmut wrote:I've tried to reproduce your problem, vertigo, and for some reason I don't know (yet) XnView behaves differently for me. And to be honest I'm not sure what the expected behaviour should be.

- After performing your steps 1-3 using "Ctrl+O" key:
Actual behaviour: XnView opens all selected images - each image in it's own tab.
Expected behaviour: ?
Yes, same here, but this appears to be a bug, as I would expect that if the setting to load multiple images opened at once in a single tab is enabled, it would do so regardless of how those images are opened. I've mentioned this in another thread discussing said setting.
helmut wrote:- After performing your steps 1-3 using "Enter" key:
Actual behaviour: XnView opens one tab showing the last selected image.
Expected behaviour: ?
Interesting. For me it displays the first selected image. But regardless, you should be able to cycle through the images (arrow keys, arrow buttons, etc) and have it only show you the ones you selected/opened. So if there are 100 images in the folder and you select and open 3, it should just cycle through those 3 and not show you the other 97. In which case, when you duplicate the tab, the new (duplicate) tab should do the same, but instead it will cycle through all 100 images.
helmut wrote:Could you please try and set "Use ENTER to switch between:" to "Do nothing" (this setting is in Tools » Settings | Interface | Switching mode)?
Already had it set like that.

Post Reply