UTF-8 comments not correctly displayed

*** Please report new bugs here! ***

Moderator: Dreamer

Post Reply
mjwurtz
Posts: 4
Joined: Fri Jul 26, 2013 8:22 pm

UTF-8 comments not correctly displayed

Post by mjwurtz » Sat Jul 27, 2013 11:52 am

Estimated severity : minor
System : Linux 64bits
Xnview version : xnView MP 0.61 language : French

When a jpeg Image comment is coded in UTF-8, it is correctly displayed in the "Exiftool" tab, but not in the "Properties" tab and the thumbnail label.
The comment editing window is OK. See example below.
Xnview_utf8.png
Xnview_utf8.png (95.17 KiB) Viewed 2163 times
Michel.

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: UTF-8 comments not correctly displayed

Post by oops66 » Sat Jul 27, 2013 12:04 pm

Bonjour Michel,
... And into Settings\Metadata\IPTC encoding\ ... you have:

Code: Select all

Default IPTC encoding = Locale (?)
Use UTF-8 to write IPTC fields (is checked ?)
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
xnview
Author of XnView
Posts: 32070
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: UTF-8 comments not correctly displayed

Post by xnview » Mon Jul 29, 2013 7:28 am

could you send me the file?
Pierre.

Gilles Maisonneuve
Posts: 1
Joined: Mon Jan 19, 2015 9:30 am

Re: UTF-8 comments not correctly displayed

Post by Gilles Maisonneuve » Mon Jan 19, 2015 10:06 am

Good morning,

Same error still present in v0.72

Able to check that jpeg/jpg file comment (named "Embedded comment" in XnViewMP "Properties" tab)
is written in Unicode (UTF8) by using ExifTool(v9.80)/ExifToolGUI(v5.15) that handles all fields (file
comment, EXIF comment, ITPC comment...) in Unicode.

With EXIFtools the comment -- set in XnViewMP -- displays properly, ex.:

Code: Select all

    C'est prouvé, le premier agencement et la première décoration de pharmacie est l'œuvre de Neandertal 
while XnViewMP file-"properties" tab, displays:

Code: Select all

    Embedded comment	C'est prouvé, le premier agencement et la première décoration de pharmacie est l'œuvre de Neandertal
I assume the migration of the "Info" tab-set display to Unicode will be done later, as this is not a blocking bug.
Still, could it be possible to have an idea of a date / version when this layout inconsistency will be addressed?

Quoi qu'il en soit, vous nous offrez là un beau logiciel pour nos photos de famille, merci Pierre.

Gilles

User avatar
xnview
Author of XnView
Posts: 32070
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: UTF-8 comments not correctly displayed

Post by xnview » Thu Feb 05, 2015 8:34 am

Gilles Maisonneuve wrote: Same error still present in v0.72
could you send me the file?
Pierre.

napfkuchen
Posts: 4
Joined: Thu Aug 22, 2013 1:44 pm

Re: UTF-8 comments not correctly displayed

Post by napfkuchen » Tue Dec 01, 2015 4:35 pm

The problem is still there (XnViewMP 0.76.1, Debian 64 bit). I added as examples three test files.
Attachments
charset-tests.zip
(364.58 KiB) Downloaded 52 times

User avatar
xnview
Author of XnView
Posts: 32070
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: UTF-8 comments not correctly displayed

Post by xnview » Tue Dec 08, 2015 8:58 am

napfkuchen wrote:The problem is still there (XnViewMP 0.76.1, Debian 64 bit). I added as examples three test files.
Please send me a file with comment?
Pierre.

User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Re: UTF-8 comments not correctly displayed - related bug reports

Post by GeorgD » Sat Oct 27, 2018 7:52 pm

In the XnView Wiki, you can improve the user guide / documentation / F1-help for XnView (classic/Windows) and for XnViewMP

Post Reply