v.0.38.2 batch rename by template not working

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

v.0.38.2 batch rename by template not working

Post by marsh »

Batch renaming a dozen jpegs with following settings will not work in 0.38.2 (they are not renamed).
[x]Name template
abcd_{Filename}

Renaming with other '[x]Replace' section is working so far.
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: v.0.38.2 batch rename by template not working

Post by xnview »

All is ok with dialog, but after pressing ok, no rename? And for 2 files?
Pierre.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: v.0.38.2 batch rename by template not working

Post by marsh »

No effect with 2 files also. No history of name template is kept also.
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: v.0.38.2 batch rename by template not working

Post by xnview »

marsh wrote:No effect with 2 files also. No history of name template is kept also.
And in filelist, the output name is ok?? It works for me :(
Pierre.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: v.0.38.2 batch rename by template not working

Post by marsh »

xnview wrote:
marsh wrote:No effect with 2 files also. No history of name template is kept also.
And in filelist, the output name is ok?? It works for me :(
An acceptable name was used, nothing to conflict with existing names. Maybe it is wine problem (though all your programs usually work well under it).
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: v.0.38.2 batch rename by template not working

Post by xnview »

marsh wrote:
xnview wrote:
marsh wrote:No effect with 2 files also. No history of name template is kept also.
And in filelist, the output name is ok?? It works for me :(
An acceptable name was used, nothing to conflict with existing names. Maybe it is wine problem (though all your programs usually work well under it).
And with 0.35 win, no problem?
Pierre.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: v.0.38.2 batch rename by template not working

Post by marsh »

No problem with 0.35 (using .38's ini).
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: v.0.38.2 batch rename by template not working

Post by xnview »

marsh wrote:No problem with 0.35 (using .38's ini).
Could you make a screenshot of the dialog? And duplicate dialog too?
Pierre.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: v.0.38.2 batch rename by template not working

Post by marsh »

Image:
Image
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: v.0.38.2 batch rename by template not working

Post by xnview »

And if you use 'replace', it works?
Pierre.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: v.0.38.2 batch rename by template not working

Post by marsh »

Replace works on all versions
User avatar
xnview
Author of XnView
Posts: 43710
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: v.0.38.2 batch rename by template not working

Post by xnview »

Ok, i the list was empty...
Pierre.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: v.0.38.2 batch rename by template not working

Post by marsh »

The updated v.0.38.3 resolves this problem. Thanks.