MP 0.26.1 (WinXP): Problem with Cyrillic characters

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

murkka
Posts: 8
Joined: Sat Aug 28, 2010 11:22 am

MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by murkka »

My local settings are Bulgarian (cyrillic) and I heve problems with unicode in EXIF Info. IPTC and XMP are OK.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43612
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by xnview »

murkka wrote:My local settings are Bulgarian (cyrillic) and I heve problems with unicode in EXIF Info. IPTC and XMP are OK.
Could you send me a sample?
Pierre.
murkka
Posts: 8
Joined: Sat Aug 28, 2010 11:22 am

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by murkka »

Is this sample OK?
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43612
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by xnview »

IPTC seems to be in Latin, and not in unicode. XMP data seems to be correct.
same here: http://newsgroup.xnview.com/viewtopic.php?f=62&t=20637
There is a bug for EXIF.XPTitle&XPAuthor
Pierre.
murkka
Posts: 8
Joined: Sat Aug 28, 2010 11:22 am

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by murkka »

IPTC seems to be in Latin,
I use both Latin and Japanese/Cyrillic. If I use just Japanese it looks like that:
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 43612
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by xnview »

murkka wrote:
IPTC seems to be in Latin,
I use both Latin and Japanese/Cyrillic. If I use just Japanese it looks like that:
I means IPTC encoding is Latin and not unicode, which software do you use?
Pierre.
murkka
Posts: 8
Joined: Sat Aug 28, 2010 11:22 am

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by murkka »

WinXP Pro Service Pack 1 ?
User avatar
xnview
Author of XnView
Posts: 43612
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by xnview »

murkka wrote:WinXP Pro Service Pack 1 ?
I think that XP use XMP, not IPTC
Pierre.
murkka
Posts: 8
Joined: Sat Aug 28, 2010 11:22 am

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by murkka »

I made a few experiments and concluded that the problem is within my OS. In Local setings - Language for non-Unicode programs when I use Bulgarian (cyrillic) I can see cyrillic but not japanese. When I use japanese I see both languages in IPTC and XMP with no problems, but I'm forced to use bulgarian.
Is there anything that can be done? Is there a way for XnView to be unrelated to local encoding and still use unicode?
User avatar
xnview
Author of XnView
Posts: 43612
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: MP 0.26.1 (WinXP): Problem with Cyrillic characters

Post by xnview »

murkka wrote: Is there anything that can be done? Is there a way for XnView to be unrelated to local encoding and still use unicode?
You must write IPTC in unicode
Pierre.