The 'Pan' cursor (hand) disapears in fullscreen panning

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

User avatar
budz45
XnThusiast
Posts: 1621
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

The 'Pan' cursor (hand) disapears in fullscreen panning

Post by budz45 »

hi again,

I see you are inundated with lot's of bugs on the ever growing XnView MP :o

Thanks again for adding Panning ability in fullscreen. I did my tests on Vista with MP 0.25. Basically there are 2 small issues I identified that need to be fixed in the 'Pan':

1. In fullscreen the Pan cursor disappears during the Panning movement and just uses the standard cursor instead of the expected 'hand' pan cursor here; http://i43.tinypic.com/xm1u0n.jpg . This loss of the cursor does not happen when XnView MP is 'windowed'. Please fix.


2. When I took a screenshot of the 'Pan' cursor in the XnView MP 'windowed' view, the cursor image grew oversized. This did not happen when I took a screenshot of the 'Pan' cursor in Paint.NET. This is a link to that same screenshot of the oversized Pan cursor in MP 0.25; http://i43.tinypic.com/2r3dz06.jpg And this is a screenshot of the Pan in Paint.NET (normal, no oversize). Please investigate and fix.

Thank you Pierre :)
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only
User avatar
xnview
Author of XnView
Posts: 43576
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: The 'Pan' cursor (hand) disapears in fullscreen panning

Post by xnview »

budz45 wrote: 2. When I took a screenshot of the 'Pan' cursor in the XnView MP 'windowed' view, the cursor image grew oversized. This did not happen when I took a screenshot of the 'Pan' cursor in Paint.NET. This is a link to that same screenshot of the oversized Pan cursor in MP 0.25; http://i43.tinypic.com/2r3dz06.jpg And this is a screenshot of the Pan in Paint.NET (normal, no oversize). Please investigate and fix.
You open 2 instances of XnMP? One with fullscreen, and one to make screenshot?
Pierre.
User avatar
budz45
XnThusiast
Posts: 1621
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: The 'Pan' cursor (hand) disapears in fullscreen panning

Post by budz45 »

xnview wrote:
budz45 wrote: 2. When I took a screenshot of the 'Pan' cursor in the XnView MP 'windowed' view, the cursor image grew oversized. This did not happen when I took a screenshot of the 'Pan' cursor in Paint.NET. This is a link to that same screenshot of the oversized Pan cursor in MP 0.25; http://i43.tinypic.com/2r3dz06.jpg And this is a screenshot of the Pan in Paint.NET (normal, no oversize). Please investigate and fix.
You open 2 instances of XnMP? One with fullscreen, and one to make screenshot?
No, no sir

I opened XnMP in fullscreen and did the screenshot with FastStone Capture. Apologies I should've mentioned "FastStone Capture" in the original bug report.
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only
User avatar
budz45
XnThusiast
Posts: 1621
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: The 'Pan' cursor (hand) disapears in fullscreen panning

Post by budz45 »

I understand that you havn't addressed these issues as yet in MP 0.26 so I'm just adding further comment.
budz45 wrote: 1. In fullscreen the Pan cursor disappears during the Panning movement and just uses the standard cursor instead of the expected 'hand' pan cursor here; http://i43.tinypic.com/xm1u0n.jpg . This loss of the cursor does not happen when XnView MP is 'windowed'. Please fix.
In the recent XnView MP 0.26.1, the Pan now shows in Fullscreen BUT for only 3 seconds before weirdly going into 'hiding'. So it needs one tine fix.
budz45 wrote: 2. When I took a screenshot of the 'Pan' cursor in the XnView MP 'windowed' view, the cursor image grew oversized. This did not happen when I took a screenshot of the 'Pan' cursor in Paint.NET. This is a link to that same screenshot of the oversized Pan cursor in MP 0.25; http://i43.tinypic.com/2r3dz06.jpg And this is a screenshot of the Pan in Paint.NET (normal, no oversize). Please investigate and fix.
I took another screenshot using FS Capture (FastStone) and the Pan cursor is still blowing up in size during 'screenshotted':
Image
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only