MP 0.21 Win - SxS Error, Fails to run [Quick-Fix]

*** Please report new bugs here! ***

Moderators: XnTriq, helmut, xnview, Dreamer

Valesk
Posts: 1
Joined: Sun Nov 22, 2009 9:31 am

MP 0.21 Win - SxS Error, Fails to run [Quick-Fix]

Post by Valesk »

Okay, here's the deal. I'm running a 32bit Windows 7 machine, but that doesn't matter. What does matter is this; I was unable to run XnView MP 2.1.

I'm sure this is a familliar sight by now;
XnViewMP\xnview.exe

The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line-sxstrace.exe tool for more detail.
Because I cannot attach the text file, I shall dump the sxstrace for your viewing pleasure;
Found
Microsoft.VC80.OpenMP

Not Found
Microsoft.VC80.OpenMP.mui


Reference is Microsoft.VC80.OpenMP,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762".
Definition is Microsoft.VC80.OpenMP,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.42".
I cut around the meat of the problem. This is the important information in the trace.

If you replace every version="8.0.50727.42" with version="8.0.50727.762" in both xnview.exe.manifest and Microsoft.VC80.OpenMP.manifest, the program will run.

I hope that this will help in future releases
gaaned92
Posts: 46
Joined: Thu Feb 11, 2010 11:55 am

Re: MP 0.21 Win - SxS Error, Fails to run [Quick-Fix]

Post by gaaned92 »

Trying MP 0.21 on XP SP3, I observed a systematic crash on a directory with .nef, .tif and .XMP files

Thanks to the trick provided by Valesk, the program no longer crashes.

Hope this can help

André
User avatar
xnview
Author of XnView
Posts: 43576
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: MP 0.21 Win - SxS Error, Fails to run [Quick-Fix]

Post by xnview »

gaaned92 wrote:Trying MP 0.21 on XP SP3, I observed a systematic crash on a directory with .nef, .tif and .XMP files
Could you send me files with crash?
Pierre.
gaaned92
Posts: 46
Joined: Thu Feb 11, 2010 11:55 am

Re: MP 0.21 Win - SxS Error, Fails to run [Quick-Fix]

Post by gaaned92 »

After analysis of directory, I found the offending file available here.

This file was obtained with following process :
- creation of tif file with RawTherapee
- creation of XMP sidecar file with exiftool (exiftool -o %d%f.xmp DIR)
- import of sidecar file inside tif file with exiftoolGUI
This was done to verify that Ptlens can read XMP data (specifically the focal length).

I can use this file with PTLENS, exiftool, Irfanview and GIMP. Gimp indicates that one XMP PS data is not valid but is able to open the file.
So I think that the structure of the metadata is valid.

nevertheless, I wonder why the above trick suppresses the crash.

André
gaaned92
Posts: 46
Joined: Thu Feb 11, 2010 11:55 am

Re: MP 0.21 Win - SxS Error, Fails to run [Quick-Fix]

Post by gaaned92 »

There is no more crash with XnViewMP 0.25 with file containing XMP metadata
Thank you
André