0.99.0 fails to load in my Linux Mint Cinnamon 20.2 [Solved]

*** Please report new bugs here! ***

Moderator: Dreamer

DanPF
Posts: 19
Joined: Tue Sep 11, 2018 3:29 pm

0.99.0 fails to load in my Linux Mint Cinnamon 20.2 [Solved]

Post by DanPF »

Hi,
I wish to report that I cannot get 0.99 to load after updating from 0.98.4

Terminal output is
"qt5ct: using qt5ct plugin
Cannot mix incompatible Qt library (5.15.1) with this library (5.15.6)"

My System is Linux Mint Cinnamon 20.2 "Uma"

Regards
DanPF
Posts: 19
Joined: Tue Sep 11, 2018 3:29 pm

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by DanPF »

As I am really i need of a working program, can someone point me to the 0.98.4 version so I can regress and keep editing until I find a fix?
Thanks Dan
User avatar
xnview
Author of XnView
Posts: 36045
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by xnview »

please try remove lib/platformthemes/libqt5ct.so, there is a problem between installed QT libs and XnView QT libs
Pierre.
DanPF
Posts: 19
Joined: Tue Sep 11, 2018 3:29 pm

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by DanPF »

Hi,
Thanks for the quick reply

The only location other than the Xnview file
is at

/lib/x86_64-linux-gnu/qt5/plugins/platformthemes

I changed the name to libqt5ct.bak

Restarted from terminal and got the exact same message. Is there anything else i can try.

In the meantime I need to regress to 0.98.4, in reality there is nothing urgent in the upgrade - either in bug fixs or New affecting me, so can you point me to the 64bit .deb file?

Thanks
Dan
User avatar
xnview
Author of XnView
Posts: 36045
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by xnview »

DanPF wrote: Fri Sep 17, 2021 12:29 pm /lib/x86_64-linux-gnu/qt5/plugins/platformthemes
Not the on from your system, but the one from XnView
In the meantime I need to regress to 0.98.4, in reality there is nothing urgent in the upgrade - either in bug fixs or New affecting me, so can you point me to the 64bit .deb file?
you have all versions here
Pierre.
DanPF
Posts: 19
Joined: Tue Sep 11, 2018 3:29 pm

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by DanPF »

I did that too. I tried changing 1 st one then the other, no effect.

Thanks for the help
Dan
DanPF
Posts: 19
Joined: Tue Sep 11, 2018 3:29 pm

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by DanPF »

Update
Previously I renamed the file, and got the same result.

However, just to be thorough, I deleted the entire file and hey presto, it now works.

Happy Bunny
Dan
pierredpt
Posts: 2
Joined: Mon Sep 20, 2021 3:42 pm
Location: France

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by pierredpt »

Sorry but this problem is not fixed.

I deleted lib/platformthemes/libqt5ct.so, but i have the same error if QT_QPA_PLATFORMTHEME=gtk2

Error : Cannot mix incompatible Qt library (5.15.1) with this library (5.15.6)

Could you fix this bug ?

Thanks
andylinpersonal
Posts: 2
Joined: Thu Sep 16, 2021 2:12 pm

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by andylinpersonal »

pierredpt wrote: Mon Sep 20, 2021 3:50 pm I deleted lib/platformthemes/libqt5ct.so, but i have the same error if QT_QPA_PLATFORMTHEME=gtk2
...
Temporary workaround - but looks ugly :| :| :| :
viewtopic.php?f=62&t=42334
cday
XnThusiast
Posts: 2986
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by cday »

I'll install 0.99.1 on my Mint 20.2 Cinnamon laptops when it is released, after confirmation that the DEB version runs without issues... :wink:
User avatar
xnview
Author of XnView
Posts: 36045
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by xnview »

ok, i found the problem, next 0.99.1 will be fixed
Pierre.
Gopher.Baroque
Posts: 2
Joined: Thu Jan 19, 2017 11:20 pm
Location: WA

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by Gopher.Baroque »

Another vote for 0.99.0 fail on Linux Mint 20.1 with Mate desktop. Glad to find link to older versions on this thread, could not spot it on the main webpages. Version 0.98.4 re-installed works fine.
User avatar
xnview
Author of XnView
Posts: 36045
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by xnview »

do you have tried 0.99.1?
Pierre.
pierredpt
Posts: 2
Joined: Mon Sep 20, 2021 3:42 pm
Location: France

Re: 0.99.0 fails to load in my Linux Mint Cinnamon 20.2

Post by pierredpt »

Bug fixed in 0.99.1
Thanks