0.99.7 Linux: Program does not suggest original file name when exporting images

Ideas for improvements and requests for new features in XnView MP

Moderators: helmut, XnTriq, xnview

postcd
Posts: 11
Joined: Sun Aug 05, 2018 10:07 am

0.99.7 Linux: Program does not suggest original file name when exporting images

Post by postcd »

Hello,
i am not running latest version mine is 0.99.7 Linux, so i want to ask if it works for You.

1. Open jpg file
2. Ctrl+Alt+S (to export)
3. Select WebP format and click Export...

ISSUE: it does not suggest me original filename and original folder so i can not simply click to confirm. (it does suggest it if the exported file type is same as source). I think it should suggest for all file types.

That is annoyance especially when needing to export multiple files. So before "Ctrl+Alt+S" i have to F2, Ctrl+C, Esc and then "Ctrl+V copied original name to export dialog. Which is annoying.
User avatar
xnview
Author of XnView
Posts: 37757
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Program does not suggest original file name when exporting images

Post by xnview »

i don't understand, original filename is always used as export filename
Pierre.
postcd
Posts: 11
Joined: Sun Aug 05, 2018 10:07 am

Re: Program does not suggest original file name when exporting images

Post by postcd »

xnview wrote: Mon May 23, 2022 12:27 pmoriginal filename is always used as export filename
Not in my case. The file name field is empty and location is user home directory (not original location).
I am launching the app like this:

Code: Select all

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=xnview --file-forwarding com.xnview.XnViewMP @@ %F @@
Happen even when opening file from user home directory.
User avatar
xnview
Author of XnView
Posts: 37757
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Program does not suggest original file name when exporting images

Post by xnview »

could you try the tgz version?
Pierre.
postcd
Posts: 11
Joined: Sun Aug 05, 2018 10:07 am

Re: Program does not suggest original file name when exporting images

Post by postcd »

xnview wrote: Tue May 24, 2022 12:05 pmcould you try the tgz version?
@xnview So I have downloaded https://download.xnview.com/XnViewMP-linux-x64.tgz , extracted, ran "./xnview.sh"
Opened image, export to webp, and it offered original name properly. Though used wrong save folder (folder where i have extracted xnview/) instead of original image folder.

Due to ease of update i prefer flatpak ( https://www.flathub.org/apps/details/co ... w.XnViewMP ) instead of tgz (where happen the issue described, how to proceed so it can be fixed?).
I assume your AppImage is not update ready i guess.