Webp 0.1.99 Support

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, xnview

Moukojin
Posts: 1
Joined: Sat Jul 21, 2012 12:54 pm

Webp 0.1.99 Support

Post by Moukojin » Sat Jul 21, 2012 1:02 pm

Hello, webp is now avaible in 0.1.99 with lossless and alpha (transparency) support. If i convert pngs in webp than i cant view them with xnview/mp :-/
I hope you guys can fix this because xnview/mp is awesome.

jgutierrez
Posts: 50
Joined: Tue Nov 15, 2005 9:25 am
Contact:

Re: Webp 0.1.99 Support

Post by jgutierrez » Wed Jul 25, 2012 5:58 pm

+1 to your suggestion.

herrbert
Posts: 1
Joined: Sun Aug 05, 2012 1:38 am

Re: Webp 0.1.99 Support

Post by herrbert » Sun Aug 05, 2012 1:40 am

+1 :p

Just converted a couple hundred PNGs to lossless WebP and can't verify the results in my favourite image viewer :(

Redfern
Posts: 12
Joined: Sat Feb 07, 2009 6:59 pm

Re: Webp 0.1.99 Support

Post by Redfern » Fri Aug 17, 2012 9:07 pm

Goggle failed to push webp as w3c standard for web pictures, so...why bothering?

User avatar
foxyshadis
Posts: 384
Joined: Sat Nov 18, 2006 8:57 am

Re: Webp 0.1.99 Support

Post by foxyshadis » Sat Aug 18, 2012 7:15 am

Redfern wrote:Goggle failed to push webp as w3c standard for web pictures, so...why bothering?
XnView already supports WebP. This is just a library update.

MaxSt
Posts: 133
Joined: Fri Apr 10, 2009 9:55 pm

Re: Webp 0.1.99 Support

Post by MaxSt » Sat Aug 18, 2012 9:19 am

Redfern wrote:Goggle failed to push webp as w3c standard for web pictures, so...why bothering?
w3c position on web graphics is use whatever formats you want.

btw, WebP version 0.2.0 is out:
http://code.google.com/p/webp/downloads/list

mdalacu
Posts: 36
Joined: Mon May 31, 2010 6:41 pm

Re: Webp 0.1.99 Support

Post by mdalacu » Tue May 21, 2013 7:01 pm

0.3 version is out.For me, MP version only displays a white screen on Linux.
Is there a setting that i must do for webp images to show?
Thank you.

User avatar
xnview
Author of XnView
Posts: 32056
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Webp 0.1.99 Support

Post by xnview » Wed May 22, 2013 4:46 pm

mdalacu wrote:0.3 version is out.For me, MP version only displays a white screen on Linux.
Is there a setting that i must do for webp images to show?
Thank you.
do you have the plugin?
Pierre.

mdalacu
Posts: 36
Joined: Mon May 31, 2010 6:41 pm

Re: Webp 0.1.99 Support

Post by mdalacu » Wed May 22, 2013 6:46 pm

No, i thought it was embedded or included with the deb file. Sorry.
How can i install it?
EDIT: i have this file /opt/XnView/Plugins/webp.so . Do i have to enable it in settings?
Thank you.

User avatar
xnview
Author of XnView
Posts: 32056
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Webp 0.1.99 Support

Post by xnview » Fri May 24, 2013 8:49 am

In Formats, do you have webp?
Pierre.

mdalacu
Posts: 36
Joined: Mon May 31, 2010 6:41 pm

Re: Webp 0.1.99 Support

Post by mdalacu » Fri May 24, 2013 2:00 pm

Sorry, but where is "Formats" in XnViewMP?
Thanks.

User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: Webp 0.1.99 Support

Post by budz45 » Fri May 24, 2013 4:41 pm

mdalacu wrote:Sorry, but where is "Formats" in XnViewMP?
Thanks.
Go to the "About" menu and you will find 'Formats' tab with a list of supported formats

About>Formats
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

mdalacu
Posts: 36
Joined: Mon May 31, 2010 6:41 pm

Re: Webp 0.1.99 Support

Post by mdalacu » Fri May 24, 2013 6:46 pm

I don't see webp listed in Formats, but i see it in Plugins Tab.
What can i do?
(thank you buds45 for your help)
P.S. I am using Ubuntu 13.04 x64.

User avatar
budz45
XnThusiast
Posts: 1597
Joined: Sun Jun 03, 2007 6:05 pm
Location: UK

Re: Webp 0.1.99 Support

Post by budz45 » Sat May 25, 2013 3:27 am

mdalacu wrote:I don't see webp listed in Formats, but i see it in Plugins Tab.
What can i do?
(thank you buds45 for your help)
P.S. I am using Ubuntu 13.04 x64.
What version of XnViewMP are you using on Linux?

Are you sure you checked the "Formats" tab properly:

Image
All My Topics || my 'MP' Topics
My own Bookmarked topics--->for me only

mdalacu
Posts: 36
Joined: Mon May 31, 2010 6:41 pm

Re: Webp 0.1.99 Support

Post by mdalacu » Sat May 25, 2013 6:46 pm

Hi, i am using the latest version available on Linux, that is 0.51 beta.
Look at my screenshots:
1.jpg
1.jpg (20.73 KiB) Viewed 1730 times
2.jpg
2.jpg (37.75 KiB) Viewed 1730 times
Is it supposed to work under Linux?
Thanks.

Post Reply