b1: No direct renaming when creating new folder

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
klumy
Posts: 229
Joined: Sat Jun 18, 2005 9:33 am

b1: No direct renaming when creating new folder

Post by klumy » Sun Dec 11, 2005 11:49 am

normally if you create a folder through the contextmenu of treeview, xnview directly create a folder named, New Folder

in Windows Explorer, the rename function is active after you have create a new folder, so you can directly enter a new name, this could also be done for xnview
XNView 1.91.5
Windows XP SP3

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: beta 1 improvment: new folder creation

Post by helmut » Sun Dec 11, 2005 12:06 pm

klumy wrote:normally if you create a folder through the contextmenu of treeview, xnview directly create a folder named, New Folder

in Windows Explorer, the rename function is active after you have create a new folder, so you can directly enter a new name, this could also be done for xnview
In Beta1 folder creation is broken (bug) so I cannot say what it's like in 1.82 beta. But from what I can see in version 1.80 you can rename a folder after creation. So you have this, already. Or did I misunderstand you?

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed Dec 14, 2005 11:36 pm

In my last post I wrote some bullshit. In 1.82 beta1, folder renaming is broken, but not folder creation.

I confirm the problem that you have reported. :bug:

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Dec 15, 2005 1:23 pm

helmut wrote:In my last post I wrote some bullshit. In 1.82 beta1, folder renaming is broken, but not folder creation.

I confirm the problem that you have reported. :bug:
No i can't confirm, "New folder" create a "New folder" edited item!
Pierre.

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Thu Dec 15, 2005 7:57 pm

xnview wrote:
helmut wrote:In my last post I wrote some bullshit. In 1.82 beta1, folder renaming is broken, but not folder creation.

I confirm the problem that you have reported. :bug:
No i can't confirm, "New folder" create a "New folder" edited item!
I experience the problem every time I create a new folder using the context menu in folder tree. What about other people?

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Fri Dec 16, 2005 12:28 pm

helmut wrote:
xnview wrote:
helmut wrote:In my last post I wrote some bullshit. In 1.82 beta1, folder renaming is broken, but not folder creation.

I confirm the problem that you have reported. :bug:
No i can't confirm, "New folder" create a "New folder" edited item!
I experience the problem every time I create a new folder using the context menu in folder tree. What about other people?
I've tried again, and once 'New folder' is added in folder tree, it is in edit mode...
Pierre.

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Sat Dec 17, 2005 10:13 am

xnview wrote:...I've tried again, and once 'New folder' is added in folder tree, it is in edit mode...
As written above I experience the problem all the time. In XnView 1.80 this works o.k., but in beta 1 this is broken. Can other users apart from klumy reproduce this? How can we continue, here?

BTW: I'm on Windows XP SP2.

User avatar
xnview
Author of XnView
Posts: 32055
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sat Dec 17, 2005 4:17 pm

helmut wrote:
xnview wrote:...I've tried again, and once 'New folder' is added in folder tree, it is in edit mode...
As written above I experience the problem all the time. In XnView 1.80 this works o.k., but in beta 1 this is broken. Can other users apart from klumy reproduce this? How can we continue, here?

BTW: I'm on Windows XP SP2.
Ok, i understand this bug is related to the bug 'can't rename folder'!!
Pierre.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Tue Dec 20, 2005 8:59 am

Used RMB>New folder in Tree to verify.

Present in b1, fixed in b2 for me.

X.

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Tue Dec 20, 2005 6:07 pm

Works for me, too. Perhaps klumy, the original tester can confirm, too.

:arrow: Closed.

Locked