b1: Problems with Firefox Cache

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
ckit
XnThusiast
Posts: 2445
Joined: Tue Feb 17, 2004 1:11 am

b1: Problems with Firefox Cache

Post by ckit » Thu Dec 08, 2005 11:34 pm

XnView 1.82 beta 1 only loads 40% thumbnails in Firefox's cache and then locks up using 100% CPU usage. Process Explorer is then needed to kill "xnview.exe"

Update 1:
Ok, I managed to locate the file in Firefox's cache that causing the problem and the same file produced a lock up with XnView's new beta shell extension as well! This file seems to be a corrupt PNG file that neither XnView or IrfanView can read.

I just reloaded XnView 1.82 alpha EXE and the same thing occurs there.

XnView needs better handling of corrupt image files.
Windows 10 Pro x64 1909
XnViewMP and Classic and PhotoFiltre Studio X

User avatar
xnview
Author of XnView
Posts: 32056
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: B1: Problems with Firefox Cache

Post by xnview » Fri Dec 09, 2005 7:54 am

ckit wrote:XnView 1.82 beta 1 only loads 40% thumbnails in Firefox's cache and then locks up using 100% CPU usage. Process Explorer is then needed to kill "xnview.exe"

Update 1:
Ok, I managed to locate the file in Firefox's cache that causing the problem and the same file produced a lock up with XnView's new beta shell extension as well! This file seems to be a corrupt PNG file that neither XnView or IrfanView can read.

I just reloaded XnView 1.82 alpha EXE and the same thing occurs there.

XnView needs better handling of corrupt image files.
Could you send me the corrupt file, please?
Pierre.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Mon Jan 09, 2006 3:52 pm

Pierre, have you got the file? Confirmed?

X.

User avatar
xnview
Author of XnView
Posts: 32056
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Jan 09, 2006 3:58 pm

Xyzzy wrote:Pierre, have you got the file? Confirmed?
For me the problem is fixed
Pierre.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Mon Jan 09, 2006 6:53 pm

ckit,
Can you confirm?

X.

ckit
XnThusiast
Posts: 2445
Joined: Tue Feb 17, 2004 1:11 am

Post by ckit » Tue Jan 10, 2006 7:16 am

It appears to be fixed.
Windows 10 Pro x64 1909
XnViewMP and Classic and PhotoFiltre Studio X

Locked