B1 - MP3 tags - most tags are missing

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

Post Reply
User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

B1 - MP3 tags - most tags are missing

Post by Dreamer » Sat Jan 10, 2009 11:25 pm

I have the mp3 files with ID3 tags, v1 and v2 (title, artist, album, track, genre...), but XnView displays only 2 items: "track num" and "year" in preview properties. In other programs (incl. explorer) all fields are visible.

This issue is also in previous version.

Windows Vista SP1, XnView 1.96 beta 1.
Dreamer

User avatar
xnview
Author of XnView
Posts: 31363
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: B1 - MP3 tags - most tags are missing

Post by xnview » Mon Jan 12, 2009 10:32 am

Could you send me a sample?
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Mon Jan 12, 2009 5:20 pm

OK, I think I got it. If there is just ID3 tag v1, it's OK, but if there is also v2 tag in the file, just some, or none tags are shown in XnView. It's probably because of missing unicode support in XnView.

Perhaps XnView should first read the v1 and only if it's missing, then read v2. I have both tags in my mp3s just because of this situation - that some program cannot read the unicode tags.

I sent two mp3s with v1 tag only and with both versions of tags to you.
Dreamer

User avatar
xnview
Author of XnView
Posts: 31363
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Jan 13, 2009 8:14 am

Yes, if tags are in unicode, xnview can't read them
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Tue Jan 13, 2009 4:20 pm

Fixed in beta 2! Thanks, Pierre.

It looks xnview can read even v2 unicode(?) tags now!?

Closed.
Dreamer

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer » Wed Jan 14, 2009 3:44 am

Dreamer wrote:Fixed in beta 2! Thanks, Pierre.

It looks xnview can read even v2 unicode(?) tags now!?

Closed.
Not really. What Pierre means is this:

- XnView can read ID3v1, ID3v2, ID3v2.3 ISO, ID3v2.3 UTF-16 and ID3v2.4. The last two have support for foreign symbols, usually referred to as 'Unicode'. But XnView will only show the info correctly if they do NOT include such foreign symbols, like Thai, Chinese, Japanese etc etc. Otherwise you will just see weired garbage (I tested that).

That said I doubt you have any such MP3s, as they normally would have the same strange file name and XnView don't process those at all.

BTW, offering support for Unicode formats but then not really supporting Unicode is a wide spread problem, especially with MP3s.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Wed Jan 14, 2009 9:39 pm

OK, I have the mp3s with some wrong characters. But as you said, it's because of missing unicode support. It's a known issue, so I think this topic should be closed. Full unicode support will be / is in MP version only.
Dreamer

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer » Thu Jan 15, 2009 2:38 am

Dreamer wrote:OK, I have the mp3s with some wrong characters. But as you said, it's because of missing unicode support. It's a known issue, so I think this topic should be closed. Full unicode support will be / is in MP version only.
And I doubt that MP will ever catch up with XnView. But that would be a different topic too...

Post Reply