B2 - Pause key is not working good - in slide show

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

B2 - Pause key is not working good - in slide show

Postby Dreamer » Thu Sep 25, 2008 9:00 pm

Pause key is not working good, it's working as <right> key to switch to the next image, so it's not possible to start/pause the slide show (.sld file).
Last edited by Dreamer on Sat Sep 27, 2008 10:20 pm, edited 1 time in total.
Dreamer

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

OH here, but…

Postby Clo » Thu Sep 25, 2008 11:08 pm

:arrow: Dreamer

:) Hello !

• I can't confirm, it works OK here and starts¦stops the "Quick Slide Show" as expected…

- Maybe it depends on your other "Keyboard / Mouse" settings ?
- However, we miss a section in that page to set the "Pause" key behaviour, IMHO.

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Postby Dreamer » Sat Sep 27, 2008 10:18 pm

Oh, sorry, I mean the slide show, not the quick slide show. Create and run .sld slide show and try again. Use these settings (replace in notepad) if you can't reproduce it.

# Slide Show Sequence
Timer = 3.000000
Loop = 1
FullScreen = 0
PlayMode = 2
WinWidth = 1400
WinHeight = 1050
MouseNav = 0
TitleBar = 0
Fit = 1
StrechVideo = 0
High = 1
CenterWindow = 0
OnTop = 1
Frame = 1
ReadErrors = 0
RandomOrder = 0
ShowText = 0
Text = <File> <Filename> <Size>KB <Width>x<Height> ((<Date> ))((<Make> ))((<Model> ))
BackgroundColor = 0
FontName = "Arial"
FontBold = 0
FontItalic = 0
FontHeight = -19
TextColor = c0c0c0
TextPosition = 0
Effect = 0
EffectMask = 16777215
Dreamer

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Postby oops66 » Sat Sep 27, 2008 10:42 pm

Hello Dreamer,
How can you test it if you have (like me) this bug first: the timer doesn't work at all in the Slide Show into the 1.95beta2 version ?
viewtopic.php?t=16024

And you mean the "space" pause hotkey or the "Pause Attn" key ?
( because both work in my system into the v1.94.2 )
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
xnview
Author of XnView
Posts: 28298
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Mon Sep 29, 2008 6:38 am

PAUSE works like SPACE
Pierre.

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Postby oops66 » Mon Sep 29, 2008 8:00 am

xnview wrote:PAUSE works like SPACE

Yes for the (normal) "Slide Show"
But No for the "Quick Slide Show"

And about the timer, do you have this bug too ?
viewtopic.php?t=16024
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
xnview
Author of XnView
Posts: 28298
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Mon Sep 29, 2008 8:27 am

oops66 wrote:
xnview wrote:PAUSE works like SPACE

Yes for the (normal) "Slide Show"
But No for the "Quick Slide Show"
In view mode? Pause start and stop quick slide for me
And about the timer, do you have this bug too ?
viewtopic.php?t=16024

Yes
Pierre.

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Postby oops66 » Mon Sep 29, 2008 8:46 am

xnview wrote:
oops66 wrote:
xnview wrote:PAUSE works like SPACE

Yes for the (normal) "Slide Show"
But No for the "Quick Slide Show"
In view mode? Pause start and stop quick slide for me

Sorry, Not here in both cases into 1.95b2 :
1-) For the "Quick Slide Show" :
In view mode or full screen mode Pause doesn't work like Space.
Pause launches or stops the timer, and Space goes to next image.
2-) For the normal "Slide Show":
Pause usually launches or stops the timer as Space, but due to this timer bug both go to next file.
Last edited by oops66 on Mon Sep 29, 2008 9:25 am, edited 3 times in total.
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
xnview
Author of XnView
Posts: 28298
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Mon Sep 29, 2008 8:49 am

oops66 wrote:Not here,
1-)For the "Quick Slide Show":
In view mode or full screen mode Pause doesn't work like Space.
Pause launches or stops the timer, and Space goes to next image.

Oh ok, right, space is used to go to next file
Pierre.

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Postby oops66 » Mon Sep 29, 2008 9:09 am

For a next release:
I think it's better to have the same keys behavior for "Slide Show" and "Quick Slide Show".
So It's better to have PAUSE = SPACE into the quick slide show as default too
(options\keybord/mouse\space = Start\Stop Quick SlideShow), like into the v1.94.2 for the normal Slide show to start or stop the timer.
(and Up/Down keys or top/bottom for next/previous too, etc...).

Without this bug too:
The Info-Text blinks two times per image into the Quick Slide Show:
viewtopic.php?t=16034

And maybe also with this suggestion:
Add into the contextual menu, and launch directly the timer into full screen mode the quick slide show function:
viewtopic.php?t=16033
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Postby Dreamer » Wed Oct 01, 2008 3:57 pm

oops66 wrote:For a next release:
I think it's better to have the same keys behavior for "Slide Show" and "Quick Slide Show".
So It's better to have PAUSE = SPACE into the quick slide show as default too
(options\keybord/mouse\space = Start\Stop Quick SlideShow), like into the v1.94.2 for the normal Slide show to start or stop the timer.

Yes, I agree, but I think more users want Space to go to next file, so perhaps also in Slide show it should be next file, don't know...
Dreamer

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Postby Dreamer » Wed Oct 01, 2008 4:03 pm

Original bug fixed.

Closed.
Dreamer


Return to “Classic - Resolved Bugs & Requests”

Who is online

Users browsing this forum: No registered users and 1 guest