Opening file from directories named using polish characters

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
chrizio
Posts: 28
Joined: Sat May 20, 2006 5:04 pm

Opening file from directories named using polish characters

Post by chrizio » Sat Jun 17, 2006 5:06 pm

I tried about already two weeks ago to create this thread as guest
but without any success. I can find it now, so here the repetition.

I have following problems with the current xnview version running
on win xp pro, sp2, engl.
If the jpeg files are placed in a directories named using polish characters
the xnview is unable to open the files (neither in full nor in the browse mode).
Following message appears then
"Error opening the file <here>".

User avatar
XnTriq
Moderator & Librarian
Posts: 5407
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Sat Jun 17, 2006 6:00 pm

I believe an application must support Unicode to be able to access files and/or folders with names that include certain Polish characters.

Forum references:

Guest

Post by Guest » Wed Jun 21, 2006 8:18 pm

XnTriq wrote:I believe an application must support to be able to access files and/or folders with names that include certain Polish characters.
Is that support in planning for the xnview next versions ?
The same history seems to be reason why the IPTC data do not display the polish special characters.

User avatar
XnTriq
Moderator & Librarian
Posts: 5407
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Wed Jun 21, 2006 8:45 pm

Anonymous wrote:Is that support in planning for the xnview next versions ?
On [url=http://newsgroup.xnview.com/viewtopic.php?p=28138#28138]03/Apr/2006[/url] xnview wrote:Many changes are planed for next version (perhaps release in september).
I'll put soon the list of new things...
Anonymous wrote:The same history seems to be reason why the IPTC data do not display the polish special characters.
On [url=http://newsgroup.xnview.com/viewtopic.php?p=16645#16645]19/Sep/2005[/url] xnview wrote:
Clo wrote::) Bonsoir,
…par exemple Montréal devient Montréal
• Très caractéristique : vos données IPTC / EXIF sont en Unicode UTF-8, et XnView n'assume pas cet affichage pour l'instant, à ce me semble…
Oui exactement.

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Jun 22, 2006 7:21 am

Anonymous wrote:
XnTriq wrote:I believe an application must support to be able to access files and/or folders with names that include certain Polish characters.
Is that support in planning for the xnview next versions ?
The same history seems to be reason why the IPTC data do not display the polish special characters.
Sorry but unicode is not planned for next release...
Pierre.

Guest

Post by Guest » Thu Jun 22, 2006 6:51 pm

xnview wrote:Sorry but unicode is not planned for next release...
Does it mean, there is no chance to get IPTC working with polish/any other language special characters in the near future too ?
Like xnview working with directories containing in theirs names national characters.

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Fri Jun 23, 2006 7:01 am

Anonymous wrote:
xnview wrote:Sorry but unicode is not planned for next release...
Does it mean, there is no chance to get IPTC working with polish/any other language special characters in the near future too ?
Like xnview working with directories containing in theirs names national characters.
I can't make that for next release, so you must wait another version, sorry...
Pierre.

Guest

Post by Guest » Sun Jun 25, 2006 3:27 pm

xnview wrote:I can't make that for next release, so you must wait another version, sorry...
I found out a workaround for the IPTC problem, missing polish characters.
Under Windows XP Pro you have to set the polish encoding for all non-unicode applications under control panel->language and region settings->advanced.
Now I can write and read properly the IPTC data containing polish characters with XnView. Problems may arise again if I move to some other PC.

User avatar
Denyer
Posts: 6
Joined: Wed May 30, 2007 6:57 pm

Post by Denyer » Thu Aug 30, 2007 5:23 pm

Is there an equivalent under 2000?

I'm also running into the problem with Latin-2 characters (such as 'ę') in filenames. XnView receives the filenames/paths without the diacritics.

Good to hear Unicode support is planned for the future. :)

Post Reply