"Save opened image(s)..." broken

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, helmut, xnview

JLsoft
Posts: 3
Joined: Sat Oct 22, 2022 3:14 am

"Save opened image(s)..." broken

Post by JLsoft »

(2.51.1)

If more than 1 image window is opened, going to File > Save opened image(s)..., selecting a destination, and hitting Copy results in files both XnView Classic and MP cannnot open ("Error opening the file <filename.ext>")

The saved files have totally random, invalid Created/Modified/Accessed timestamps...
User avatar
xnview
Author of XnView
Posts: 38702
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: "Save opened image(s)..." broken

Post by xnview »

i can't reproduce, which format?
Pierre.
JLsoft
Posts: 3
Joined: Sat Oct 22, 2022 3:14 am

Re: "Save opened image(s)..." broken

Post by JLsoft »

Can you try Tools > Capture Screen twice (with Open in XnView selected), and then Save opened image(s)?

It will save out 2 .PNGs, and here: XnView can't open them, and in Explorer's Properties, the timestamps are random (and the timestamp column in the Explorer 'Details' view is blank.
User avatar
xnview
Author of XnView
Posts: 38702
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: "Save opened image(s)..." broken

Post by xnview »

i've tried but no problem in the output png
Pierre.
JLsoft
Posts: 3
Joined: Sat Oct 22, 2022 3:14 am

Re: "Save opened image(s)..." broken

Post by JLsoft »

Okay, I found that it's not the file's format causing the problem here, it's the timestamps.


If I change all 3 (created/modified/accessed) dates and times to something recent, XnView can open the same file fine.


I have no idea what's causing the bad timestamps when XnView saves the files to disk...the only system setting relating to time I can think of here that I've done is the common "Disable NTFS Last Access Time Updates" tweak.

Oh well...at least now I know how to work around this.