Webp support...

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Koogle
Posts: 117
Joined: Wed Sep 20, 2006 3:23 pm

Webp support...

Post by Koogle »

webp not supported on classic.. updated the webp plugin and it still doesn't show webp files...

meanwhile xnviewMP displays the same webp files just fine..

???

should xnview classic even need a plugin for webp..shouldn't it be part of the installation now?
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Webp support...

Post by xnview »

it's already in the package, lastest version?
Pierre.
Koogle
Posts: 117
Joined: Wed Sep 20, 2006 3:23 pm

Re: Webp support...

Post by Koogle »

yup latest.. just put latest in again to overwrite the webp dll

it does show the webp file in the browser.. but when trying to view in the viewer.. it just goes to a browser... and if opening from explorer the same.. and the option show display all image types is on.

So I dunno? it does kinda work, just not how I normally view images, as I don't usually use the xnview browser
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Webp support...

Post by xnview »

in browser, do you have preview of webp? you can't open webp from browser to viewer?
Pierre.
Koogle
Posts: 117
Joined: Wed Sep 20, 2006 3:23 pm

Re: Webp support...

Post by Koogle »

yes the preview of the webp files work.. but going to viewer just nothing.. and opening the webp file directly.. nothing..xnview goes the browser and not the viewer
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Webp support...

Post by xnview »

Koogle wrote: Fri Jan 29, 2021 2:11 pm yes the preview of the webp files work.. but going to viewer just nothing.. and opening the webp file directly.. nothing..xnview goes the browser and not the viewer
from windows explorer?
Pierre.
Koogle
Posts: 117
Joined: Wed Sep 20, 2006 3:23 pm

Re: Webp support...

Post by Koogle »

yup.. happens with .ico files aswel.. but they show fine in browser
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Webp support...

Post by xnview »

Koogle wrote: Mon Feb 01, 2021 2:27 pm yup.. happens with .ico files aswel.. but they show fine in browser
i think that you have a bad registry entry for webp
Pierre.
Koogle
Posts: 117
Joined: Wed Sep 20, 2006 3:23 pm

Re: Webp support...

Post by Koogle »

how would I find out/fix that? win10
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Webp support...

Post by xnview »

with regedit
Pierre.
User avatar
XnTriq
Moderator & Librarian
Posts: 5922
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Webp support...

Post by XnTriq »

Koogle wrote: Mon Feb 01, 2021 6:46 pmhow would I find out/fix that? win10
This free utility might be helpful:
https://www.nirsoft.net/utils/file_types_manager.html wrote:FileTypesMan is an alternative to the 'File Types' tab in the 'Folder Options' of Windows. It displays the list of all file extensions and types registered on your computer. For each file type, the following information is displayed: Type Name, Description, MIME Type, Perceived Type, Flags, Browser Flags, and more.
FileTypesMan also allows you to easily edit the properties and flags of each file type, as well as it allows you to add, edit, and remove actions in a file type.
Koogle
Posts: 117
Joined: Wed Sep 20, 2006 3:23 pm

Re: Webp support...

Post by Koogle »

thanks, yeah webp files opening properly now.. was stupid windows had xnview.exe but not the arg for file opening

anyway,.. seems to still be some webp files that don't open (and also don't show in the browser view).. seems to be animated webp files.. is the codec supporting that?
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Webp support...

Post by xnview »

Koogle wrote: Sat Feb 06, 2021 6:54 pm thanks, yeah webp files opening properly now.. was stupid windows had xnview.exe but not the arg for file opening

anyway,.. seems to still be some webp files that don't open (and also don't show in the browser view).. seems to be animated webp files.. is the codec supporting that?
animated webp are only supported in XnView MP
Pierre.
Koogle
Posts: 117
Joined: Wed Sep 20, 2006 3:23 pm

Re: Webp support...

Post by Koogle »

is that not something that could be ported to classic? I still prefer it

Again xniewMP is just slower to startup than classic, and I usually just open images from the explorer, so waiting for xnviewmp to load is tad annoying... talking like seconds longer when both classic/mp are on a ramdisk.. should be instant like classic is...side issue I guess already made comment about it here viewtopic.php?p=167178#p167178 along with the issue of " [View]>[Auto-Image-Resize]>[Fit image to desktop, large only] <<<which still does not exist in MP and yet I find incredibly useful."