Glitchy Amiga IFF/ILBM image

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
Hobbe
Posts: 47
Joined: Mon Oct 16, 2006 8:30 pm

Glitchy Amiga IFF/ILBM image

Post by Hobbe » Thu Oct 15, 2015 1:21 am

I can't seem to get this one to display properly on the latest version of XnView Classic. I know it ain't something wrong with the file itself because it looks correctly on Deluxe Paint.

Just letting you know, peradventure it can be fixed.

Best regards and thank you so much for this wonderful piece of software 8)
Attachments
mangled.7z
(14.15 KiB) Downloaded 101 times

jason_s
Posts: 4
Joined: Mon Oct 03, 2011 11:01 pm

Re: Glitchy Amiga IFF/ILBM image

Post by jason_s » Sat Oct 17, 2015 11:29 pm

Probably because of the 1-bit transparency mask, which is a rare type of ILBM transparency.

Here are two more examples:
MachHinDuGaul.lha -> CYCLONE-MachHinDuGaul
smirnoff.lha -> Smirnoff_MagicWB.ilbm

Mixer
Posts: 166
Joined: Fri Aug 28, 2015 6:24 am

Re: Glitchy Amiga IFF/ILBM image

Post by Mixer » Tue Nov 03, 2015 5:13 am

And on attempt of Reopening (Ctrl+R)those files XnView rejects them throwing message window:

Warning
Format of the file <filename> could not be determined
For displaying of less common formats, the following option is available:
Options>General>[x]Display all image file types

Even though "Display all image file types" is already selected in options.
--edit-- ...but it happens only in a very old OS
In newer OS it just shows Type: Unknown in picture's Properties.
--edit2-- disregard this, Type in Properties displays information based on registry data for file extension.
So if you name .lbm as .jpg it will show Type: JIF Image and Type: Unknown if extension has no default application for opening it.

Post Reply