XnView 2.32 crash on HIDDEN files if "Loop file list" active

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
namfrey
Posts: 2
Joined: Thu May 21, 2015 8:08 am

XnView 2.32 crash on HIDDEN files if "Loop file list" active

Post by namfrey » Sun Jul 26, 2015 11:37 am

Hi.

The bug I'm experiencing was already described here:
http://newsgroup.xnview.com/viewtopic.p ... lit=hidden

Sadly it was never fixed. :( That report from 2011 concerned version 1.98.

I'm now using 2.32 on Windows 7 SP1 x86 right now, and it still persists.

If "Loop file list" option is active, then if in Windows Explorer I double-click a file which has its "hidden" or "system" or both attribute set, then XnView loads and displays the file fine, but then immediately the xnview.exe process crashes.

If I disable the "Loop file list" option, then XnView opens same file without crashing.

I would like XnView not to crash like that.
Can we get this very old and very annoying bug addressed in some foreseeable future?

Thank you in advance.
Regards.

Koogle
Posts: 104
Joined: Wed Sep 20, 2006 3:23 pm

Re: XnView 2.32 crash on HIDDEN files if "Loop file list" ac

Post by Koogle » Thu Aug 13, 2015 11:47 am

i agree that bug has been in there for many years

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView 2.32 crash on HIDDEN files if "Loop file list" ac

Post by xnview » Mon Aug 17, 2015 1:24 pm

do you use the 'read ahead behind' option?
Pierre.

namfrey
Posts: 2
Joined: Thu May 21, 2015 8:08 am

Re: XnView 2.32 crash on HIDDEN files if "Loop file list" ac

Post by namfrey » Mon Aug 17, 2015 2:19 pm

xnview wrote:do you use the 'read ahead behind' option?
hi!
thanks for the reply.

to answer your question: yes, this option is active.

strangely enough, the issue seems to be gone after installing 2.33.

first when I still used 2.32 I disabled "Loop file list" and forget about the problem.

then I updated to 2.33, and now as you asked me, I checked and hidden and even system files open by double-click as intended.

has this particular thing been patched between 2.32 and 2.33 ?

I'm now in the process of downgrading and checking the 2.32 version again. I'll be back with the report.

back with the report. I can't reproduce it =\

I even created a new fresh profile and everything's seems alright. so most probably there was something wrong inside my Windows installation which affected XnView or Explorer while opening the file. I sincerely don't know what I did to fix it. but be sure if the problem reoccurs I'll be back reporting.

thanks for the attention anyway. I'll keep this topic open for a day or two just to be sure I'm doing everything I can to test it properly.
cheers.

Post Reply