Crash when entering folder with a movie

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

thany2
Posts: 28
Joined: Mon Apr 29, 2013 9:29 am

Crash when entering folder with a movie

Post by thany2 » Mon Feb 17, 2014 7:51 pm

XnView crashes when entring a folder that happens to contain a MKV file. I can't say anything about the crash, because it's one of those "...has stopped working" crashes. I have no way of getting any information out of that, that might be useful.

This crash is 100% reproducible. All that appears to be neccesary, is for a MKV file to be in a folder, and browsing to that folder.

If you need more information, just lemme know what you need and how to get it.

I'm using XnView 2.13 on Windows 7 x64.
Using XnView 2.13 on Windows 7 x64
Cheers!

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Crash when entering folder with a movie

Post by xnview » Tue Feb 18, 2014 2:37 pm

Could you send me the movie, please?
Pierre.

thany2
Posts: 28
Joined: Mon Apr 29, 2013 9:29 am

Re: Crash when entering folder with a movie

Post by thany2 » Wed Feb 19, 2014 12:03 am

I wish I could, but these are copyrighted movies.

But I think it's safe to say this problem occurs for *any* MKV file, as far as I've been able to test. If you can download any 1080p movie in MKV from the internet you should be able to reproduce the problem - because it happens for all of them. If not, then perhaps XnView doesn't like something related. Perhaps it tries to fiddle with decoders in a way that makes it crash.

The movies in question play absolutely fine, both on VLC and on DirectShow-based players.
Using XnView 2.13 on Windows 7 x64
Cheers!

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Crash when entering folder with a movie

Post by xnview » Wed Feb 19, 2014 8:25 am

i have no problem with mkv, i have klite codec pack
Pierre.

thany2
Posts: 28
Joined: Mon Apr 29, 2013 9:29 am

Re: Crash when entering folder with a movie

Post by thany2 » Wed Feb 19, 2014 9:39 am

Okay, so that tells me it's using installed codecs, rather than built-in ones. That's what makes it unreliable by definition, because there's no way of knowing what a user might have installed.

I'm using The matroska splitter from Haali, and for decoding I use ffdshow. I guess I'll update ffdshow and see if that helps. But mind you, nothing else, not even windows explorer, shows any sign of problems when dealing with these files.
Using XnView 2.13 on Windows 7 x64
Cheers!

diggeryo
Posts: 4
Joined: Thu Feb 20, 2014 1:44 pm

Re: Crash when entering folder with a movie

Post by diggeryo » Thu Feb 20, 2014 1:51 pm

I am having the same issue as THANY2, though I don't seem to have an MKV file in any of the folders with issues.

XnView doesn't crash when I go into every folder with a movie, only some. And I'm not sure what they have in common that is causing the crash. Like THANY2, I can view these folders in Windows Explorer (with or without thumbnails being shown) and don't have any issue.

I am running Windows 7 64-bit with SP1 and all latest updates installed. I have XnView v2.13 installed. I have K-Lite Codec Pack v10.3 installed.

I'm pretty sure this issue started sometime within the past two weeks. In that time, I've updated my installed K-Lite to v10.3 and also installed the Microsoft updates from last Patch Tuesday. I would assume someone in one of those updates is the culprit.

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Crash when entering folder with a movie

Post by xnview » Fri Feb 21, 2014 9:07 am

which format do you have in this folder?
Pierre.

diggeryo
Posts: 4
Joined: Thu Feb 20, 2014 1:44 pm

Re: Crash when entering folder with a movie

Post by diggeryo » Sat Feb 22, 2014 2:54 am

It contains:

3g2
flv
mpa
mpg
mpeg
mp4
avi
wmv

None of the files are newer than when the issue started within the past few weeks.

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Crash when entering folder with a movie

Post by xnview » Sat Feb 22, 2014 8:09 am

could you try to check if one format is the problem?
Pierre.

diggeryo
Posts: 4
Joined: Thu Feb 20, 2014 1:44 pm

Re: Crash when entering folder with a movie

Post by diggeryo » Sat Feb 22, 2014 12:34 pm

It seems to happen with the MP4 files, though not all of them. I've narrowed down the files in this particular folder to one that causes the error and one that doesn't.

Here's one that causes the error:
https://dl.dropboxusercontent.com/u/472 ... istake.mp4

Here's one that doesn't:
https://dl.dropboxusercontent.com/u/472 ... icken).mp4

Here is a more complete description of the issue: I go into XnView and all is ok. Once I click on a folder that has a "bad" file, I get several icons appear and disappear quickly in my system tray. I believe these are from K-Lite Codec pack. This "process" has always occurred when I go into a folder containing movies in XnView.

Anyway, after it goes through of few of these icons, finally I get the error message (I assume once the "bad" file was reached). Note that this "icons in system tray" process still occurs when the "bad" file is not in the folder, but, of course, I don't get the error message.

Lastly, just so we're on the same page, I can go into the folders that contain "bad" files in Windows explorer and not experience any issues. (though the "icons in system tray" process doesn't happen in Windows explorer, only in XnView.)

Hope this helps.

User avatar
xnview
Author of XnView
Posts: 31267
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Crash when entering folder with a movie

Post by xnview » Sun Feb 23, 2014 2:43 pm

do you have installed Quicktime?
Pierre.

diggeryo
Posts: 4
Joined: Thu Feb 20, 2014 1:44 pm

Re: Crash when entering folder with a movie

Post by diggeryo » Sun Feb 23, 2014 4:39 pm

I do. And when you mentioned that, it reminded me of an issue I had with iTunes a couple weeks ago. I couldn't get it to update properly, so I uninstalled it.

Even though Quicktime is still on my computer, when I tried to go into it, I got an error message. So I uninstalled it and reinstalled it. Now no issues in Xnview!!! Thanks so much for your help!!

thany2
Posts: 28
Joined: Mon Apr 29, 2013 9:29 am

Re: Crash when entering folder with a movie

Post by thany2 » Mon Feb 24, 2014 8:56 am

I don't have Quicktime installed, but I do Quicktime Alternative... I'll see if uninstalling that helps. I'm not really using it anyway.
Using XnView 2.13 on Windows 7 x64
Cheers!

loopingz
Posts: 17
Joined: Sat Jul 18, 2009 11:31 pm

Re: Crash when entering folder with a movie

Post by loopingz » Wed Feb 26, 2014 9:15 pm

I do crash for most movie done with my fujifilm XF1.
Tell me if you want me to send a video...

loopingz
Posts: 17
Joined: Sat Jul 18, 2009 11:31 pm

Re: Crash when entering folder with a movie

Post by loopingz » Wed Feb 26, 2014 9:27 pm

They are .mov Uninstalling Quicktime alternative solved the issue... There might be some kind of conflict.

Post Reply