Unable to Add Open File Item to Toolbar in XnView 1.98.8

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
ZBTSI
Posts: 8
Joined: Sat May 05, 2012 9:38 pm

Unable to Add Open File Item to Toolbar in XnView 1.98.8

Post by ZBTSI » Sat May 05, 2012 10:03 pm

I am running XnView 1.98.8 on three computers; two that run Windows XP,
and one running Windows 7.

I have found that I cannot add the Open File item to the toolbar from the
user interface in this version. While I am able to delete items or move
them around on the toolbar, I cannot successfully create a new Open File
item. This is reproducible on all three machines.

To duplicate the issue, perform the following steps.

1. From the main menu bar, select tools > options > interface > toolbar.

2. Click on browser. You will see that the drop-down command list is
unavailable at this point.

3. Click on append. From the drop-down command list, select cmd_Open [Open..].
You will note that the icon for the Open command appears at the end of
the toolbar preview line.

4. Highlight the icon, then Click the left-arrow to move it to the desired
position on the toolbar, then click OK.

5. Close and restart XnView. You will note that instead of the Open icon
appearing where it should, XnView instead displays a separator at that
position.

I do notice that if I try to add other commands, such as Capture, I am
able to do so successfully. Other commands apparently need an external
icon file, which I don't have on hand at this point.

If anyone can verify this on their system, I'd appreciate hearing about it.

Regards,

Thomas

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: Unable to Add Open File Item to Toolbar in XnView 1.98.8

Post by marsh » Sat May 05, 2012 11:23 pm

Confirmed. Editing settings by hand produces same result. [Browser Toolbar] button##=0 gets reset to button##=-1

ZBTSI
Posts: 8
Joined: Sat May 05, 2012 9:38 pm

Re: Unable to Add Open File Item to Toolbar in XnView 1.98.8

Post by ZBTSI » Wed Jun 06, 2012 4:46 am

marsh wrote:Confirmed. Editing settings by hand produces same result. [Browser Toolbar] button##=0 gets reset to button##=-1
Hi again marsh.

I'm seeing this issue also in 1.99 with the "Old Toolbar" skin. I haven't tried any
other skins yet, but I plan to. Am I using the correct procedure to add the icon?

Thanks.

Thomas

ZBTSI
Posts: 8
Joined: Sat May 05, 2012 9:38 pm

Re: Unable to Add Open File Item to Toolbar in XnView 1.98.8

Post by ZBTSI » Wed Jun 06, 2012 5:37 am

Oops!

Finally found the release notes in the program directory. It's not mentioned, so
I will check back on this again in the next version.

Thomas

Post Reply