giant thumbnail cache

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
obelisk
Posts: 402
Joined: Fri Jan 09, 2009 9:54 am

giant thumbnail cache

Post by obelisk » Sun Jan 18, 2009 8:32 am

I have some folders with jpg files. thumbnail cache set to jpg lossy - low qual

the size shown is:

images size
11 307kb
14 800kb
17 1017kb


Why is this? thumbnails are 200x200
My other pc 11 images would take 80kb and it's using jpg lossy - high qual.

User avatar
bmezenga
Posts: 25
Joined: Fri Nov 09, 2007 1:44 am

Post by bmezenga » Sun Jan 18, 2009 2:30 pm

Hi obelisk;

Your observation may be related to mine.

This discussion was continued by e-mail, so the result was:
- XnView copy all metadata info to its cache. This means: thumbnail, exif and makernotes. This behavior can´t be configured yet.

In my case, I found that the Pentax K100D makernotes are a lot bigger than my old Lumix LZ5 and I just stopped using the cache feature.

Disabling the cache didn´t had any negative impact because XnView can read the thumbnail embedded in the jpg and pef files from my camera.

User avatar
xnview
Author of XnView
Posts: 31887
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sun Jan 18, 2009 3:58 pm

bmezenga wrote: This discussion was continued by e-mail, so the result was:
- XnView copy all metadata info to its cache. This means: thumbnail, exif and makernotes. This behavior can´t be configured yet.
No not all, exif thumbnail is not saved in DB. I need iptc & exif for thumbnail labels...
Pierre.

obelisk
Posts: 402
Joined: Fri Jan 09, 2009 9:54 am

Post by obelisk » Sun Jan 18, 2009 10:12 pm

yes it is a pentax k10d and ist*D jpgs giving the large caches

User avatar
xnview
Author of XnView
Posts: 31887
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Jan 19, 2009 7:57 am

obelisk wrote:yes it is a pentax k10d and ist*D jpgs giving the large caches
Could you send me samples to check?
Pierre.

User avatar
xnview
Author of XnView
Posts: 31887
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Jan 20, 2009 2:06 pm

Ok, the problem is size of makernotes...
Pierre.

obelisk
Posts: 402
Joined: Fri Jan 09, 2009 9:54 am

Post by obelisk » Sat Feb 14, 2009 7:34 am

What is the solution here? I have a 920MB cache now, at low qual jpeg

User avatar
bmezenga
Posts: 25
Joined: Fri Nov 09, 2007 1:44 am

Re: giant thumbnail cache

Post by bmezenga » Wed Sep 30, 2009 12:21 am

Hi Pierre,

Thumbnail cache is working as expected for Pentax raw and camera jpeg files.
i.e.: it doesn´t store Exif makernotes in the DB.

However, jpeg files created by Pentax Photo Laboratory v3.61 are different enough to fool your actual filter.

I just sent you some samples.
Last edited by bmezenga on Thu Oct 01, 2009 9:53 pm, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 31887
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: giant thumbnail cache

Post by xnview » Wed Sep 30, 2009 12:43 pm

bmezenga wrote: However, jpeg files created by Pentax Photo Laboratory v3.61 are different enough to fool your actual filter.
I just sent you some samples.
Ok, i'll check
Pierre.

Post Reply