Page 1 of 1

Manual zoom turns off HQ when switching to/from fullscreen

Posted: Mon Dec 22, 2008 10:17 pm
by nintendomaniac64
The following bug was tested in 1.95.4 and was in several older versions as well (don't know if it was always there or just a regression though)...
______________________________________________________________________________________________

If you use the manual +Zoom or -Zoom buttons/function (with HQ zoom on) while in windowed, then go to fullscreen, the HQ filter turns off. This also happens if you're in fullscreen, change the zoom level, and then go back to windowed.

Also, when using manually-set zoom (like 150%) and locking zoom level, the HQ filter is still turned off when switching from/to fullscreen. (but when you go to next image, the filter is there)

This does NOT happen though if you select a non-percentage zoom like "fit to window".
______________________________________________________________________________________________

Here's a video showing what I'm talking about. MAKE SURE YOU VIEW IN HIGH QUALITY (or HD if it becomes available)

http://www.youtube.com/watch?v=YTsR40f_xsQ
______________________________________________________________________________________________

EDIT: It seems I've found another bug while testing this one. Sometimes if you go to fullscreen, change the zoom level while still in fullscreen, then go back to windowed, the zoom level will revert back to the level it was at before you fullscreen'd. The video shows this bug as well, though I don't know exactly when it happens yet.

Posted: Tue Dec 23, 2008 8:18 am
by pic_viewer
Very good! I have problems with HQ Zoom ever since but never was able to track down why it works sometimes then not. I always have XnView browser left monitor, F11 right monitor. Mostly the fullscreen pic on the right does not use HiQ Zoom.

I hope that your bug has the same root so I will get HQ Zoom finally all the time...

Posted: Mon Jan 05, 2009 12:09 am
by pic_viewer
Ok, I try to explain how it now behaves on my single display system (notebook). I hope it is reproducable!

- HQ Zoom is activated in Options (both ticked)

- State: browser. Press F11, selected pic is shown full screen. Press + button several times - works in real time, pixels are seen, so HQ is not working.

- State browser. Hit enter, selected file is shown in window with full screen size. Press + button several times - long wait as HQ is working , no pixels shown.

- Now press F11: the window frame disappears but HQ Zoom is still working when using + and - keys!

Same situation on my dual monitor system where I have browser left and full screen via F11 on the right: HQ Zoom never works when coming from the browser.

Posted: Mon Jan 05, 2009 8:24 am
by pic_viewer
I just noticed that nintendomaniac describes the exact same bug as I do. But maybe my description is more clear (at least to me ;-)

Posted: Mon Jan 05, 2009 3:50 pm
by nintendomaniac64
Well, I was trying more to explain what situations it happens in. You were giving more of an example of when it happens, which is what I designed the video for. ;)

Posted: Sat Jan 10, 2009 10:04 am
by pic_viewer
What a pity that this oldtimer didn't make it into 1.96. When will it be fixed?

Posted: Mon Jan 12, 2009 9:59 am
by xnview
pic_viewer wrote:What a pity that this oldtimer didn't make it into 1.96. When will it be fixed?
I'll try for next release...