Incorrect display of a png image

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
DarkBlood
Posts: 7
Joined: Sun Mar 23, 2008 5:52 pm
Location: Argentina
Contact:

Incorrect display of a png image

Post by DarkBlood » Thu Dec 11, 2008 8:25 am

Problematic image:
Image


INCORRECT DISPLAY:
Image


CORRECT DISPLAY:
Image


My configuration of xnview:
Image[/list]

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Incorrect display of a png image

Post by xnview » Thu Dec 11, 2008 12:45 pm

Please enable 'Use alpha channel'
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 5434
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Incorrect display of a png image

Post by XnTriq » Thu Dec 11, 2008 5:30 pm

xnview wrote:Please enable 'Use alpha channel'
This setting has no effect, because we're dealing with a grayscale PNG. :|

My own “collection” so far:Webshots.com and others use translucent PNGs to allow their users to switch the site's color scheme on the fly (i.e. w/o loading additional page elements): Links of interest:
Last edited by XnTriq on Fri Dec 12, 2008 3:03 am, edited 1 time in total.

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Re: Incorrect display of a png image

Post by pic_viewer » Fri Dec 12, 2008 2:20 am

xnview wrote:Please enable 'Use alpha channel'
I dare to say: there is no such option. All I find is the opposite, 'Ignore alpha channel'.

User avatar
XnTriq
Moderator & Librarian
Posts: 5434
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Incorrect display of a png image

Post by XnTriq » Fri Dec 12, 2008 3:10 am

pic_viewer wrote:
xnview wrote:Please enable 'Use alpha channel'
I dare to say: there is no such option. All I find is the opposite, 'Ignore alpha channel'.
I dare to disagree: View » Use alpha channel (Ctrl+H).

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Re: Incorrect display of a png image

Post by pic_viewer » Fri Dec 12, 2008 4:38 am

XnTriq wrote:
pic_viewer wrote:
xnview wrote:Please enable 'Use alpha channel'
I dare to say: there is no such option. All I find is the opposite, 'Ignore alpha channel'.
I dare to disagree: View » Use alpha channel (Ctrl+H).
So with Pierre's totally clear hint I searched for half an hour in Options for this entry. After your note I looked again and did not find it anywhere. I then noticed the underscore V and looked in the menu - nowhere to find. 5 minutes later I realize that I am in browser mode. Change to Viewer and there it is.

Now someone just needs to explain to me why the options >Enable Alpha channel, Ignore Alpha channel, Compose image with alpha< , not to mention the extra transparency option, are in any way logical and self-explanatory...

User avatar
XnTriq
Moderator & Librarian
Posts: 5434
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Incorrect display of a png image

Post by XnTriq » Fri Dec 12, 2008 5:15 am

pic_viewer wrote:Now someone just needs to explain to me why the options >Enable Alpha channel, Ignore Alpha channel, Compose image with alpha< , not to mention the extra transparency option, are in any way logical and self-explanatory...
XnTriq ([url=http://newsgroup.xnview.com/viewtopic.php?p=68042#68042]PNG 32 BPP wrongly displayed…[/url]) wrote:
Clo wrote:• However, I think that this option as it's set is totally illogical, unclear and confusing…
- Besides, there are too many scattered options about the Alpha channel and transparency,
I'ld like them grouped and clear…
+1

Post Reply