Bug: PNG transparency showed with artefacts

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Micha
Posts: 78
Joined: Thu Feb 08, 2007 12:51 pm

Post by Micha » Fri Nov 21, 2008 12:43 pm

Image

This are the PNG read options. I'm not sure what means "Alpha is enabled?", but I can switch on/off the alpha per Ctrl-H, that works for the preview image, but I don't want to get a transparent image. I'm looking for a black disk at white ground. If I enable the alpha of the preview, than I get the XnView grey as background, but no the white of the image background.

I'm not sure what the is the best way to recreate the thumbnails. I copied the test image to a new directory and look at this directory. A new thumbnail should be created or?

User avatar
xnview
Author of XnView
Posts: 31598
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Fri Nov 21, 2008 1:25 pm

You would like that:
Image
Pierre.

Micha
Posts: 78
Joined: Thu Feb 08, 2007 12:51 pm

Post by Micha » Fri Nov 21, 2008 1:45 pm

Yes and No. I like, that your example show the white background without artefacts at the downscaled image "PNG_test", but I don't like, that the sky background is not visible at the original image "Eiche.png". I would like to see the background at both images, sky at "Eiche" and white at "test".

Or is the background color destroyed by Photoshop, so that PNG_Test dosn't contain any background info? And all other image software show the transparency with a white background allways? In this case, XnView could only support an option like "transparency fill color for missing background" for images without background info. But maybe it's a problem to detect, is a background at the PNG available or not. In this case you can't do anything.

One thing could be done - if I take my black disk image and I try to convert it to an image without transparency, than I used the convert function and convert the image to true colours. In this case I get a black quadrat. Could you make, that the transparency is taken in acount and the background is filled with white (or better the user can choose the color)?

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer » Sat Nov 22, 2008 1:15 pm

This thread is totally confusing. So far I found out:

- the circle test file from the first post is shown as black square when 'Ignore Alpha Channel' is checked in Options/General/Operations. As I never changed this setting the default (unchecked) shows a circle and seems to be correct.

- As mentioned above to see the picture as intended (transparent, XnView is a viewer...) the option 'Compose Image with alpha (32 bits)' must be unchecked. This is not the default setting, which is highly disappointing as nobody will ever find this setting - nor understand it - IMHO.

Micha
Posts: 78
Joined: Thu Feb 08, 2007 12:51 pm

Post by Micha » Sat Nov 22, 2008 2:01 pm

@pic_viewer: I checked the options again and I use the same settings like you, but get squares. :(

pic_viewer
Posts: 251
Joined: Sat Nov 17, 2007 7:53 am
Location: Germany

Post by pic_viewer » Sat Nov 22, 2008 10:59 pm

Well, and I don't fully understand where exactly the problem is. What I see on my system is that the thumbnail in the browser is always shown transparent, no matter which option I use. Is it there where you want to see it without transparency?

Is the black square effect in preview mode on your system? Did you try with a fresh ini? There must be more settings influencing this if it works on my system but not on yours.

Post Reply