"Save selection as custom" doesn't work

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
jens116
Posts: 36
Joined: Tue Jul 05, 2005 8:38 am

"Save selection as custom" doesn't work

Post by jens116 » Fri Feb 02, 2007 7:08 am

If you use the the Custom Selection in 1.90 many interesting things happen but not the right one. Sometimes the selection frame collapse to a very small selection and sometimes the vertikal orientation is transformed into an horizontal orientation.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

*Peanuts*

Post by Clo » Fri Feb 02, 2007 7:29 am

:) Hello !

• This function no longer works here, I get nothing after I saved a custom selection and try to reuse it !

• It worked fine in 1.82.4…

:mrgreen: VG
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "Save selection as custom" doesn't work

Post by xnview » Fri Feb 02, 2007 1:37 pm

jens116 wrote:If you use the the Custom Selection in 1.90 many interesting things happen but not the right one. Sometimes the selection frame collapse to a very small selection and sometimes the vertikal orientation is transformed into an horizontal orientation.
Ratio or size? i have no problem...
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Size…

Post by Clo » Fri Feb 02, 2007 1:43 pm

:) I tested “Size” here.

- It works perfectly in 1.82.4 and not at all in 1.90 final…
- It seems saved, since the menu entry turns "On", but when using it, nothing happens.
- Accuracy : I know that handling so well, I described it in our Manual, though I don't use it a lot…

Note : It's lost when closing¦restarting XnView… The entry comes back to greyed.

:mrgreen: KR
Claude
Old user ON SELECTIVE STRIKE till further notice

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Size…

Post by xnview » Fri Feb 02, 2007 1:50 pm

Clo wrote::) I tested “Size” here.

- It works perfectly in 1.82.4 and not at all in 1.90 final…
- It seems saved, since the menu entry turns "On", but when using it, nothing happens.
- Accuracy : I know that handling so well, I described it in our Manual, though I don't use it a lot…
Can't reproduce, i open a picture, select an area, use Edit/Selection size/Save, click on picture to clean the selection, use Edit/Selection size/Custom, and i have the old selection....
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

*nope*

Post by Clo » Fri Feb 02, 2007 1:57 pm

:D … and here I've NOTHING !

XP-Pro SP1 still…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: "Save selection as custom" doesn't work

Post by Dreamer » Fri Feb 02, 2007 8:03 pm

I can't confirm this bug too, it works good, even after xnview restart.
Dreamer

jens116
Posts: 36
Joined: Tue Jul 05, 2005 8:38 am

Re: "Save selection as custom" doesn't work

Post by jens116 » Mon Feb 05, 2007 9:10 am

jens116 wrote:If you use the the Custom Selection in 1.90 many interesting things happen but not the right one. Sometimes the selection frame collapse to a very small selection and sometimes the vertikal orientation is transformed into an horizontal orientation.
Here some additional information: The described problem refers to the Selection Ratio function. But the Selection Size is also wrong. If you click Custom in the Selection Size menu the Ratio-Function is switched on although you don't ask for that. There seems to be an additional cross over problem between the menus. Here my system: XP with SP2.

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "Save selection as custom" doesn't work

Post by xnview » Mon Feb 05, 2007 12:29 pm

jens116 wrote:
jens116 wrote:If you use the the Custom Selection in 1.90 many interesting things happen but not the right one. Sometimes the selection frame collapse to a very small selection and sometimes the vertikal orientation is transformed into an horizontal orientation.
Here some additional information: The described problem refers to the Selection Ratio function. But the Selection Size is also wrong. If you click Custom in the Selection Size menu the Ratio-Function is switched on although you don't ask for that.
Ok, i have the size swap, i'll fix it in a 1.90.1
Pierre.

Post Reply