2.43: STRG+C doesnt work in Viewer

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
surfacecleanerz
Posts: 78
Joined: Thu Dec 15, 2005 10:59 am
Location: Germany
Contact:

2.43: STRG+C doesnt work in Viewer

Post by surfacecleanerz » Sat Feb 10, 2018 3:34 pm

Hi,
when I press STRG+C in XNViews Viewer mode and then change to an Windows 8.1 file folder window and press STRG+V or right click\insert, it is greyed out, because the clipboard is empty.

In the XNView file browser it is working via right click\copy, but this way is extremely slow. When I change to file browser tab, use copy and return to viewer mode it is reloading the catalogue and until it is finished it will switch to the wrong next file because I'm using sort by EXIF date.

If you need more information, feel free to ask!

Additional information:
The folder contains 6000 files from an holiday with different names because some are from a camera and some from 3 different mobile phones. I'm viewing the files one after another and if I find a good picture I rename it by F2 and then I want to copy it to a best of subfolder.

Thank you for your great tool!

regards,
Stefan

User avatar
xnview
Author of XnView
Posts: 29260
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by xnview » Mon Feb 12, 2018 11:29 am

in view mode, Ctrl+C copy the image
Pierre.

surfacecleanerz
Posts: 78
Joined: Thu Dec 15, 2005 10:59 am
Location: Germany
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by surfacecleanerz » Tue Feb 13, 2018 4:47 pm

Hi,
this doesn't work in Win 8.1 with 2.43 de and english!

What do you need?

It is not in the Windows clipboard!

In browser mode it works!

regards,
Stefan

User avatar
xnview
Author of XnView
Posts: 29260
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by xnview » Wed Feb 14, 2018 12:16 pm

i've tried again, and image (only) is copied in clipboard
and if you use Edit>Copy?
Pierre.

surfacecleanerz
Posts: 78
Joined: Thu Dec 15, 2005 10:59 am
Location: Germany
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by surfacecleanerz » Thu Feb 15, 2018 6:03 am

Hi,
thank you for your response.

No, via edit/copy it is not there, either.

Any ideas? Do you need something?

To make it clear: this is, when I see a picture in the full window (not full screen mode, but with window borders). In Xnviews file browser mode it works without a problem.

Edit: In full screen STRG+C doesn't work. Right click is not possible, there is only copy to...

Regards,
Stefan

User avatar
xnview
Author of XnView
Posts: 29260
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by xnview » Thu Feb 15, 2018 2:40 pm

and if you select an area, and copy?
Pierre.

surfacecleanerz
Posts: 78
Joined: Thu Dec 15, 2005 10:59 am
Location: Germany
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by surfacecleanerz » Sat Mar 31, 2018 12:14 pm

Hi,
I tried in XnView MP, there it works. In 2.44 the file is not copied into clipboard.

I want to copy a file from the folder (with all images of a trip) to a subfolder with a subset of images, which I think are good.

If I select an area, the file is not in the clipboard, when I try to paste into a explorer folder. But that is a normal behaviour, because the format of the data is wrong.

Or what do you mean?

In general XnView MP is much faster in indexing pictures. I have folders with 4000 to 9000 jpg pictures in them and there the sorting after EXIF date is VEEERy slow (around 2 minutes) in file browser mode.

It would be very nice, if after renaming one file (either in viewer or in file browser mode) XnView (MP) is not generating a full new index of the folder, but edit the existing index. So it lags. The file with the edited name is sorted as one of the last files in the folder and after around 30 s to a minute its preview is shown, then I can use the reload button and the after some seconds it is at the right place in the folder.

The folders are mixed folders with fotos taken by mobile phones and by camera with different naming schemes. So I have to use the EXIF date.

Thank you for your great softwares!!!

Happy Easter!

Kind regards,
Stefan

User avatar
xnview
Author of XnView
Posts: 29260
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by xnview » Tue Apr 03, 2018 7:31 am

surfacecleanerz wrote: I tried in XnView MP, there it works. In 2.44 the file is not copied into clipboard.
In Viewer (XnView Classic), Ctrl+C copy the image data, not file
Pierre.

surfacecleanerz
Posts: 78
Joined: Thu Dec 15, 2005 10:59 am
Location: Germany
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by surfacecleanerz » Tue Apr 03, 2018 10:38 pm

Hi,
ok, is it possible to change that via a setting?

What do you say to my request regarding the long lasting index generation after renaming?

Regards,
Stefan

User avatar
xnview
Author of XnView
Posts: 29260
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by xnview » Wed Apr 04, 2018 7:20 am

surfacecleanerz wrote: ok, is it possible to change that via a setting?
you can set in [view] section

Code: Select all

CopyClipboard=2
What do you say to my request regarding the long lasting index generation after renaming?
in XnView MP?
Pierre.

surfacecleanerz
Posts: 78
Joined: Thu Dec 15, 2005 10:59 am
Location: Germany
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by surfacecleanerz » Wed Apr 04, 2018 9:46 pm

xnview wrote: What do you say to my request regarding the long lasting index generation after renaming?


in XnView MP?
Hi,
in both programs, but in classic it is even slower than in MP.

The entry in the .ini works, as desired! Thnk you!

Regards,
Stefan

User avatar
xnview
Author of XnView
Posts: 29260
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by xnview » Thu Apr 05, 2018 5:20 am

surfacecleanerz wrote: in both programs, but in classic it is even slower than in MP.
so after you rename ONE file in the browser, all thumbnails are re-generated?
Pierre.

surfacecleanerz
Posts: 78
Joined: Thu Dec 15, 2005 10:59 am
Location: Germany
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by surfacecleanerz » Thu Apr 05, 2018 6:56 pm

Hi,
if I rename one file in either file browser or view mode and then in file browser mode the renamed image is shown not at the right location, but as one of the last ones in the folder and without thumbnail image. The view in the preview window (in file browser mode) is shown the whole time. After the green bar at the right bottom is at ~30% the thumbnail of the renamed file is shown and the hitting the reload button akes the renamed file shown at the right location.

I sort by EXIF date, as written before!

This makes sorting out good pictures in a folder a time cosuming thing. Renaming a file and copy it to the subfolder with good pictures and return to the next picture in the row (sorted by EXIF date) consumes around 2 minutes per picture in XNView classic. In MP this is around 30s.

Do you need pictures to show this?

At the moment I have a folder with 3500 pictures (only .jpg).

In the subfolder, where I have the RAW files it is even more time consuming. But this is not the folder I use often.

To clarify it: I rename in XNView not in the windows explorer!

Regards,
Stefan

User avatar
xnview
Author of XnView
Posts: 29260
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 2.43: STRG+C doesnt work in Viewer

Post by xnview » Fri Apr 06, 2018 6:49 am

you means that after renaming, the renamed file is not correctly sorted?
Pierre.

Post Reply