xhtml Plugin - Support for html,htm,mht,eml,nws file types

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Wed Jan 09, 2008 5:59 pm

Does the Xhtm plugin run on Windows Vista? Does it work with XnView 1.92?

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Wed Jan 09, 2008 8:47 pm

helmut wrote:Does the Xhtm plugin run on Windows Vista? Does it work with XnView 1.92?
I don't know, i'll test it, and author doesn't reply anymore...
Pierre.

User avatar
Nikolay Raspopov
Posts: 89
Joined: Thu Jun 24, 2004 4:25 pm
Location: Sarov, Russia
Contact:

Post by Nikolay Raspopov » Thu Jan 10, 2008 5:37 pm

huh!? i got no requests from you. 8)

btw i dont know either, i have no Vista (yet).
Image

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Jan 10, 2008 8:47 pm

Nikolay Raspopov wrote:huh!? i got no requests from you. 8)

btw i dont know either, i have no Vista (yet).
Could you send me your email by PM, please?
Pierre.

User avatar
Nikolay Raspopov
Posts: 89
Joined: Thu Jun 24, 2004 4:25 pm
Location: Sarov, Russia
Contact:

Post by Nikolay Raspopov » Fri Jan 11, 2008 3:44 am

my e-mail is the same as always: ryo-oh-ki [at] narod [dot] ru.
Image

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Fri Jan 11, 2008 7:00 am

Nikolay Raspopov wrote:my e-mail is the same as always: ryo-oh-ki [at] narod [dot] ru.
Not the mail that i had :-) I've sent you an email
Pierre.

User avatar
Nikolay Raspopov
Posts: 89
Joined: Thu Jun 24, 2004 4:25 pm
Location: Sarov, Russia
Contact:

Post by Nikolay Raspopov » Mon Jan 14, 2008 5:27 pm

Image

ckit
XnThusiast
Posts: 2441
Joined: Tue Feb 17, 2004 1:11 am

Post by ckit » Tue Jan 15, 2008 1:18 am

Huge thanks!
Let us know if you add CSS support too!
Windows 10 Pro x64 1903
XnViewMP and Classic and PhotoFiltre Studio X

User avatar
Nikolay Raspopov
Posts: 89
Joined: Thu Jun 24, 2004 4:25 pm
Location: Sarov, Russia
Contact:

Post by Nikolay Raspopov » Fri Jan 18, 2008 8:45 pm

Image

ikutluay
Posts: 15
Joined: Wed Aug 08, 2007 7:59 am

Post by ikutluay » Wed Jan 23, 2008 3:39 pm

i have 3000+ xhtml+css template. if this works then it will be very good for me..

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Feb 26, 2008 10:24 am

Any idea why it doesn't work for me under Vista? all htm, html etc. files keep their icon instead of showing the preview; inserting or removing their extensions in the Browser|File list options doesn't change anything.

I have copied the XnView folder from my XP machine, where it worked, and have maintained all the same settings. Both on my old XP and new Vista I have Avant Browser as the default browser (an IE shell) and IE7 installed.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Feb 26, 2008 10:30 am

I just tried to switch back IE as the default, but no change... apart from PDF files losing their preview also :shock: and getting it back when I restored Avant as the default browser. Really cannot understand...

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Feb 26, 2008 4:15 pm

Installing Ghostscript (the latest, 8.61) as suggested here http://newsgroup.xnview.com/viewtopic.php?p=13481#13481 was useless.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Feb 26, 2008 5:34 pm

Sorry for the long string of posts, but I'm reporting as I'm testing and checking the issue. Don't know if it may be of interest, but neither the working installation on the XP machine nor the Vista installation display the Xhtml plugin in the Info|Plugins dialog... should it appear alongside the others even if it's a .usr plugin and not a "native" .dll plugin?

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Tue Feb 26, 2008 8:18 pm

Works fine for me one Windows XP. Some hints for trouble shooting:

1 - The HTML plug-in must be unpacked in Subfolder .\Plugins

2 - By default the HTML plugin displays preview or image view of the HTML, but no thumbnails are shown (probably for security reasons). If you want to see thumbnails for HTML, HTM, MTH, ... files, you have to open Tools > Options > Browser > File List and activate the appropriate checkboxes for "Custom files".

- Please note that the HTML plugin is NEVER listed as plug-in or add-on in Info > Plug-Ins Information.

- FAIK, the HTML plugin uses the IE control or API to render the HTML. There's no need to install GhostScript.

Post Reply