Incorrect Colours & ICC Profiles

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, helmut, xnview

HarvsPhotos
Posts: 3
Joined: Sat Feb 10, 2024 7:37 pm

Incorrect Colours & ICC Profiles

Post by HarvsPhotos »

XnView Classic V2.51.5

I apologise if this is covered elsewhere on the forum but I have searched and cannot find an answer.

I find that images viewed in XnView are over saturated and have a red hue. I am working in a colour managed environment and have a reasonable understanding of ICC profiles & colour management but am unable to configure XnView Classic to render JPGs correctly.

An image exported as a JPG from Lightroom with an embedded profile, either sRGB or AdobeRGB produces the same incorrect result.
The same image viewed in Photoshop, Affinity Photo or even the Windows Photos app render the image correctly and match the Lightroom original.

I can confirm that the images have an embedded profile as (reported by Photoshop) and that I have configued the ICC setttings in XnView to use the embedded profiles if present.

Viewing the sRGB & AdobeRGB versions of the image in XnView shows identical colours for both, thus proving XnView is using the embedded colour profile, but the final result is wrong.

I attach a screenshot showing the same JPG viewed in 4 applications, the bottom left is the incorrect XnView
I also attach my ICC settings in XnView.

Any help would be appreciated.
You do not have the required permissions to view the files attached to this post.
HarvsPhotos
Posts: 3
Joined: Sat Feb 10, 2024 7:37 pm

Re: Incorrect Colours & ICC Profiles

Post by HarvsPhotos »

Has nobody else seen the same issue or have a solution to what I'm seeing? :(

I wonder of XnViewMP behaves the same way.
User avatar
xnview
Author of XnView
Posts: 43611
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Incorrect Colours & ICC Profiles

Post by xnview »

HarvsPhotos wrote: Mon Feb 12, 2024 5:22 pm I wonder of XnViewMP behaves the same way.
Could you try?
Pierre.
HarvsPhotos
Posts: 3
Joined: Sat Feb 10, 2024 7:37 pm

Re: Incorrect Colours & ICC Profiles

Post by HarvsPhotos »

Had a go with XnView MP and that is working correctly so will switch to that.