BMP file not displayed

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
guest1702

BMP file not displayed

Post by guest1702 » Sun Feb 17, 2008 8:18 pm

The viewer shows this image as white. The browser shows a normal thumbnail of it as white, too, but a folder thumbnail is shown correctly.

When I turn BMP animation on, then the above is true, except for the viewer, it shows the first half (top) and the second half (bottom) of the image alternately.

Here's the BMP file:
Image

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Untick Alpha

Post by Clo » Sun Feb 17, 2008 9:11 pm

:arrow: guest1702

:) Hello !

• Go to View Menu and untick the box “Use Alpha channel”, or press CTRL+H.

• It's displayed alright here such as (it's a 32 BPP BMP…)

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

guest1702

Post by guest1702 » Sun Feb 17, 2008 9:44 pm

Thanks, I didn't notice that. (Using IrfanView which apparently doesn't support alpha channels in BMPs).

In the end my solution was to remove the 100% transparency from the file. :wink:

But it's still concerning, IMHO, that activating "animation" in BMP files had an effect on this file. XnView should have shown a fully transparent image with this setting enabled, or am I mistaken?

Guest

Post by Guest » Sun Feb 17, 2008 9:52 pm

guest1702 wrote:But it's still concerning, IMHO, that activating "animation" in BMP files had an effect on this file. XnView should have shown a fully transparent image with this setting enabled, or am I mistaken?
Oh wait, I get it. It's somehwat of an unsupported feature: I remember the IE world animation being in BMP format with all the frames underneath each other. I guess that's meant with BMP animations?

User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Post by Drahken » Mon Feb 18, 2008 9:03 am

Animated BMP files are a filmstrip-like image (it can be vertical or horizontal). AFAIK, the BMP itself doesn't truly animate, instead the program which displays it displays only one portion at a time, then moves to the next one.

V3nd4
Posts: 2
Joined: Sun Feb 24, 2008 2:32 pm

Re: Untick Alpha

Post by V3nd4 » Sun Feb 24, 2008 2:34 pm

Clo wrote::arrow: guest1702

:) Hello !

• Go to View Menu and untick the box “Use Alpha channel”, or press CTRL+H.

• It's displayed alright here such as (it's a 32 BPP BMP…)

:mrgreen: Kind regards,
Claude
Clo
Thanx a lot. It solved my problem.

Post Reply